The GPipe-GLFW package

[maintain]

GPipe-GLFW is a utility library to enable the use of GLFW as the OpenGL window and context handler for GPipe. GPipe is a typesafe functional API based on the conceptual model of OpenGL, but without the imperative state machine.

Properties

Versions1.0, 1.1, 1.2.1, 1.2.2, 1.2.3, 1.3.0, 1.3.0
Dependenciesbase (>=4.7 && <4.10), exception-transformers, GLFW-b (==1.4.*), GPipe (==2.1.*), GPipe-GLFW, transformers (>=0.3 && <0.6) [details]
LicenseMIT
CopyrightPatrick Redmond
AuthorPatrick Redmond
MaintainerPatrick Redmond
StabilityExperimental
CategoryGraphics
Home pagehttps://github.com/plredmond/GPipe-GLFW
Source repositoryhead: git clone https://github.com/plredmond/GPipe-GLFW.git(GPipe-GLFW)
this: git clone https://github.com/plredmond/GPipe-GLFW.git(tag v1.3.0)(GPipe-GLFW)
Executablesgpipe-glfw-smoketests
UploadedThu Dec 8 04:18:21 UTC 2016 by plredmond

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees