Build #1 for GenSmsPdu-0.1

[all reports]

Package GenSmsPdu-0.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted unknown
Compiler ghc-7.6.3
OS linux
Arch x86_64
Dependencies random-1.0.1.1, haskell98-2.0.0.2, base-4.6.0.1, QuickCheck-2.6
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring QuickCheck-2.6...
Building QuickCheck-2.6...
Preprocessing library QuickCheck-2.6...
[ 1 of 13] Compiling Test.QuickCheck.Exception ( Test/QuickCheck/Exception.hs, dist/build/Test/QuickCheck/Exception.o )
[ 2 of 13] Compiling Test.QuickCheck.Text ( Test/QuickCheck/Text.hs, dist/build/Test/QuickCheck/Text.o )
[ 3 of 13] Compiling Test.QuickCheck.State ( Test/QuickCheck/State.hs, dist/build/Test/QuickCheck/State.o )
[ 4 of 13] Compiling Test.QuickCheck.Gen ( Test/QuickCheck/Gen.hs, dist/build/Test/QuickCheck/Gen.o )
[ 5 of 13] Compiling Test.QuickCheck.Arbitrary ( Test/QuickCheck/Arbitrary.hs, dist/build/Test/QuickCheck/Arbitrary.o )
[ 6 of 13] Compiling Test.QuickCheck.Poly ( Test/QuickCheck/Poly.hs, dist/build/Test/QuickCheck/Poly.o )
[ 7 of 13] Compiling Test.QuickCheck.Modifiers ( Test/QuickCheck/Modifiers.hs, dist/build/Test/QuickCheck/Modifiers.o )
[ 8 of 13] Compiling Test.QuickCheck.Function ( Test/QuickCheck/Function.hs, dist/build/Test/QuickCheck/Function.o )
[ 9 of 13] Compiling Test.QuickCheck.Property ( Test/QuickCheck/Property.hs, dist/build/Test/QuickCheck/Property.o )
[10 of 13] Compiling Test.QuickCheck.Test ( Test/QuickCheck/Test.hs, dist/build/Test/QuickCheck/Test.o )
[11 of 13] Compiling Test.QuickCheck.Monadic ( Test/QuickCheck/Monadic.hs, dist/build/Test/QuickCheck/Monadic.o )
[12 of 13] Compiling Test.QuickCheck  ( Test/QuickCheck.hs, dist/build/Test/QuickCheck.o )
[13 of 13] Compiling Test.QuickCheck.All ( Test/QuickCheck/All.hs, dist/build/Test/QuickCheck/All.o )
In-place registering QuickCheck-2.6...
Running Haddock for QuickCheck-2.6...
Running hscolour for QuickCheck-2.6...
Preprocessing library QuickCheck-2.6...
Preprocessing library QuickCheck-2.6...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0, random-1.0.1.1
Haddock coverage:
  12% (  1 /  8) in 'Test.QuickCheck.Exception'
   0% (  0 / 18) in 'Test.QuickCheck.Text'
  50% (  1 /  2) in 'Test.QuickCheck.State'
  95% ( 20 / 21) in 'Test.QuickCheck.Gen'
  92% ( 23 / 25) in 'Test.QuickCheck.Arbitrary'
  14% (  1 /  7) in 'Test.QuickCheck.Poly'
  92% ( 12 / 13) in 'Test.QuickCheck.Modifiers'
  14% (  1 /  7) in 'Test.QuickCheck.Function'
  59% ( 34 / 58) in 'Test.QuickCheck.Property'
  48% ( 13 / 27) in 'Test.QuickCheck.Test'
   7% (  1 / 15) in 'Test.QuickCheck.Monadic'
 100% (  9 /  9) in 'Test.QuickCheck.All'
  93% ( 95 /102) in 'Test.QuickCheck'
Warning: Test.QuickCheck.Text: could not find link destinations for:
    Test.QuickCheck.Text.Output
Warning: Test.QuickCheck.State: could not find link destinations for:
    System.Random.StdGen
Warning: Test.QuickCheck.Gen: could not find link destinations for:
    System.Random.StdGen System.Random.Random
Warning: Test.QuickCheck.Arbitrary: could not find link destinations for:
    System.Random.Random
Warning: Test.QuickCheck.Property: could not find link destinations for:
    Test.QuickCheck.Exception.AnException
Warning: Test.QuickCheck.Test: could not find link destinations for:
    System.Random.StdGen
Warning: Test.QuickCheck: could not find link destinations for:
    System.Random.StdGen System.Random.Random
Documentation created: dist/doc/html/QuickCheck/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/QuickCheck-2.6/ghc-7.6.3
Registering QuickCheck-2.6...
Installed QuickCheck-2.6
Downloading GenSmsPdu-0.1...
Configuring GenSmsPdu-0.1...
Building GenSmsPdu-0.1...
Preprocessing executable 'gensmspdu' for GenSmsPdu-0.1...

on the commandline: Warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

src/Main.hs:1:1:
    Ambiguous module name `Prelude':
      it was found in multiple packages: base haskell98-2.0.0.2
Failed to install GenSmsPdu-0.1
cabal: Error: some packages failed to install:
GenSmsPdu-0.1 failed during the building phase. The exception was:
ExitFailure 1