Build #9 for Hieroglyph-3.2

[all reports]

Package Hieroglyph-3.2
Install DependencyFailed buster-2.21
Docs NotTried
Tests NotTried
Time submitted 2016-12-31 20:49:44.395471 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies IfElse-0.85, OpenGL-3.0.1.0, array-0.5.1.1, base-4.9.0.0, buster-2.21, buster-gtk-2.0, bytestring-0.10.8.1, cairo-0.13.3.1, colour-2.3.3, containers-0.5.7.1, glib-0.13.4.1, gtk-0.14.6, gtkglext-0.13.1.1, mtl-2.2.1, parallel-3.2.1.0, pretty-1.1.3.3, random-1.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring ObjectName-1.1.0.1...
Configuring colour-2.3.3...
Building ObjectName-1.1.0.1...
Building colour-2.3.3...
Installed ObjectName-1.1.0.1
Configuring dataenc-0.12...
Building dataenc-0.12...
Configuring fixed-0.2.1.1...
Installed dataenc-0.12
Building fixed-0.2.1.1...
Configuring half-0.2.2.3...
Installed colour-2.3.3
Building half-0.2.2.3...
Configuring old-locale-1.0.0.7...
Installed fixed-0.2.1.1
Building old-locale-1.0.0.7...
Configuring mtl-2.2.1...
Installed half-0.2.2.3
Building mtl-2.2.1...
Configuring parallel-3.2.1.0...
Installed old-locale-1.0.0.7
Building parallel-3.2.1.0...
Configuring random-1.1...
Installed parallel-3.2.1.0
Building random-1.1...
Configuring primitive-0.6.1.0...
Installed mtl-2.2.1
Building primitive-0.6.1.0...
Configuring stm-2.4.4.1...
Installed random-1.1
Building stm-2.4.4.1...
Configuring utf8-string-1.0.1.1...
Installed primitive-0.6.1.0
Building utf8-string-1.0.1.1...
Configuring text-1.2.2.1...
Installed stm-2.4.4.1
Building text-1.2.2.1...
Installed utf8-string-1.0.1.1
Configuring IfElse-0.85...
Building IfElse-0.85...
Configuring StateVar-1.1.0.4...
Installed IfElse-0.85
Building StateVar-1.1.0.4...
Configuring vector-0.11.0.0...
Installed StateVar-1.1.0.4
Building vector-0.11.0.0...
Installed text-1.2.2.1
Configuring hashable-1.2.4.0...
Building hashable-1.2.4.0...
Configuring OpenGLRaw-3.2.4.0...
Installed hashable-1.2.4.0
Building OpenGLRaw-3.2.4.0...
Configuring parsec-3.1.11...
Installed vector-0.11.0.0
Building parsec-3.1.11...
Installed parsec-3.1.11
Configuring buster-2.21...
Building buster-2.21...
Configuring hashtables-1.2.1.0...
Failed to install buster-2.21
Build log ( /home/builder/.cabal/logs/buster-2.21.log ):
cabal: Entering directory '/tmp/cabal-tmp-31523/buster-2.21'
Configuring buster-2.21...
Warning: The 'license-file' field refers to the file '' which does not exist.
Building buster-2.21...
Preprocessing library buster-2.21...
[1 of 6] Compiling App.EventBus     ( App/EventBus.hs, dist/build/App/EventBus.o )

App/EventBus.hs:224:10: error:
    • Illegal instance declaration for ‘Monoid (Behaviour a)’
        (All instance types must be of the form (T a1 ... an)
         where a1 ... an are *distinct type variables*,
         and each type variable appears at most once in the instance head.
         Use FlexibleInstances if you want to disable this.)
    • In the instance declaration for ‘Monoid (Behaviour a)’
cabal: Leaving directory '/tmp/cabal-tmp-31523/buster-2.21'
Building hashtables-1.2.1.0...
Installed hashtables-1.2.1.0
Configuring gtk2hs-buildtools-0.13.2.1...
Building gtk2hs-buildtools-0.13.2.1...
Installed gtk2hs-buildtools-0.13.2.1
Configuring glib-0.13.4.1...
Building glib-0.13.4.1...
Configuring cairo-0.13.3.1...
Installed glib-0.13.4.1
Building cairo-0.13.3.1...
Installed cairo-0.13.3.1
Configuring pango-0.13.3.1...
Building pango-0.13.3.1...
Configuring gio-0.13.3.1...
Installed pango-0.13.3.1
Building gio-0.13.3.1...
Installed OpenGLRaw-3.2.4.0
Configuring GLURaw-2.0.0.3...
Installed gio-0.13.3.1
Configuring gtk-0.14.6...
Building GLURaw-2.0.0.3...
Building gtk-0.14.6...
Installed GLURaw-2.0.0.3
Configuring OpenGL-3.0.1.0...
Building OpenGL-3.0.1.0...
Installed OpenGL-3.0.1.0
Installed gtk-0.14.6
Configuring gtkglext-0.13.1.1...
Building gtkglext-0.13.1.1...
Installed gtkglext-0.13.1.1
cabal: Error: some packages failed to install:
Hieroglyph-3.2 depends on buster-2.21 which failed to install.
buster-2.21 failed during the building phase. The exception was:
ExitFailure 1
buster-gtk-2.0 depends on buster-2.21 which failed to install.