Build #3 for JuPyTer-notebook-0.1.0.0

[all reports]

Package JuPyTer-notebook-0.1.0.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-11-21 13:55:43.150186848 UTC
Compiler ghc-8.0.2
OS linux
Arch x86_64
Dependencies base-4.9.1.0, json-autotype-1.0.18, aeson-1.2.3.0, base-4.9.1.0, bytestring-0.10.8.1, json-autotype-1.0.18, text-1.2.2.2
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring GenericPretty-1.2.1...
Configuring base-compat-0.9.3...
Building GenericPretty-1.2.1...
Building base-compat-0.9.3...
Installed GenericPretty-1.2.1
Configuring base-orphans-0.6...
Building base-orphans-0.6...
Configuring cabal-doctest-1.0.3...
Installed base-compat-0.9.3
Building cabal-doctest-1.0.3...
Configuring colour-2.3.3...
Installed base-orphans-0.6
Building colour-2.3.3...
Configuring call-stack-0.1.0...
Installed cabal-doctest-1.0.3
Building call-stack-0.1.0...
Configuring dlist-0.8.0.3...
Installed call-stack-0.1.0
Building dlist-0.8.0.3...
Configuring fail-4.9.0.0...
Installed colour-2.3.3
Configuring integer-logarithms-1.0.2...
Installed dlist-0.8.0.3
Building fail-4.9.0.0...
Building integer-logarithms-1.0.2...
Configuring parallel-3.2.1.1...
Installed fail-4.9.0.0
Building parallel-3.2.1.1...
Configuring mtl-2.2.1...
Installed integer-logarithms-1.0.2
Building mtl-2.2.1...
Configuring prelude-extras-0.4.0.3...
Installed parallel-3.2.1.1
Building prelude-extras-0.4.0.3...
Configuring primitive-0.6.2.0...
Installed mtl-2.2.1
Building primitive-0.6.2.0...
Configuring random-1.1...
Installed prelude-extras-0.4.0.3
Building random-1.1...
Configuring reflection-2.1.2...
Installed random-1.1
Building reflection-2.1.2...
Configuring semigroups-0.18.3...
Installed primitive-0.6.2.0
Building semigroups-0.18.3...
Configuring stm-2.4.4.1...
Installed semigroups-0.18.3
Building stm-2.4.4.1...
Configuring syb-0.7...
Installed reflection-2.1.2
Building syb-0.7...
Configuring text-1.2.2.2...
Installed stm-2.4.4.1
Building text-1.2.2.2...
Configuring th-abstraction-0.2.6.0...
Installed syb-0.7
Building th-abstraction-0.2.6.0...
Configuring time-locale-compat-0.1.1.3...
Installed th-abstraction-0.2.6.0
Building time-locale-compat-0.1.1.3...
Configuring transformers-compat-0.5.1.4...
Installed time-locale-compat-0.1.1.3
Building transformers-compat-0.5.1.4...
Configuring void-0.7.2...
Installed transformers-compat-0.5.1.4
Building void-0.7.2...
Installed void-0.7.2
Configuring ansi-terminal-0.7.1.1...
Building ansi-terminal-0.7.1.1...
Configuring StateVar-1.1.0.4...
Installed ansi-terminal-0.7.1.1
Configuring vector-0.12.0.1...
Installed text-1.2.2.2
Building StateVar-1.1.0.4...
Building vector-0.12.0.1...
Configuring exceptions-0.8.3...
Installed StateVar-1.1.0.4
Building exceptions-0.8.3...
Configuring mmorph-1.1.0...
Installed exceptions-0.8.3
Building mmorph-1.1.0...
Configuring transformers-base-0.4.4...
Installed mmorph-1.1.0
Building transformers-base-0.4.4...
Configuring tagged-0.8.5...
Installed transformers-base-0.4.4
Building tagged-0.8.5...
Installed tagged-0.8.5
Configuring ansi-wl-pprint-0.6.8.1...
Building ansi-wl-pprint-0.6.8.1...
Configuring monad-control-1.0.2.2...
Installed ansi-wl-pprint-0.6.8.1
Building monad-control-1.0.2.2...
Configuring contravariant-1.4...
Installed monad-control-1.0.2.2
Building contravariant-1.4...
Configuring hashable-1.2.6.1...
Installed vector-0.12.0.1
Configuring distributive-0.5.3...
Installed contravariant-1.4
Building hashable-1.2.6.1...
Building distributive-0.5.3...
Installed hashable-1.2.6.1
Configuring lifted-base-0.2.3.11...
Building lifted-base-0.2.3.11...
Warning: /tmp/pkgConf-distributive-0.59908929211760243555.3: Unrecognized
field dynamic-library-dirs on line 22
Configuring optparse-applicative-0.14.0.0...
Installed distributive-0.5.3
Building optparse-applicative-0.14.0.0...
Configuring scientific-0.3.5.2...
Installed lifted-base-0.2.3.11
Building scientific-0.3.5.2...
Configuring uuid-types-1.0.3...
Installed scientific-0.3.5.2
Building uuid-types-1.0.3...
Configuring unordered-containers-0.2.8.0...
Installed optparse-applicative-0.14.0.0
Building unordered-containers-0.2.8.0...
Installed uuid-types-1.0.3
Configuring comonad-5.0.2...
Building comonad-5.0.2...
Configuring resourcet-1.1.9...
Installed unordered-containers-0.2.8.0
Building resourcet-1.1.9...
Warning: /tmp/pkgConf-comonad-5.07711514321186452551.2: Unrecognized field
dynamic-library-dirs on line 29
Configuring attoparsec-0.13.2.0...
Installed comonad-5.0.2
Building attoparsec-0.13.2.0...
Installed resourcet-1.1.9
Configuring bifunctors-5.4.2...
Building bifunctors-5.4.2...
Configuring uniplate-1.6.12...
Installed attoparsec-0.13.2.0
Building uniplate-1.6.12...
Configuring conduit-1.2.12.1...
Installed bifunctors-5.4.2
Building conduit-1.2.12.1...
Installed uniplate-1.6.12
Configuring aeson-1.2.3.0...
Building aeson-1.2.3.0...
Configuring profunctors-5.2.1...
Installed conduit-1.2.12.1
Building profunctors-5.2.1...
Configuring semigroupoids-5.2.1...
Installed profunctors-5.2.1
Building semigroupoids-5.2.1...
Installed aeson-1.2.3.0
Configuring yaml-0.8.25...
Building yaml-0.8.25...
Warning: /tmp/pkgConf-semigroupoids-5.21504569917680466996.1: Unrecognized
field dynamic-library-dirs on line 60
Installed semigroupoids-5.2.1
Configuring free-4.12.4...
Building free-4.12.4...
Installed free-4.12.4
Configuring adjunctions-4.3...
Installed yaml-0.8.25
Building adjunctions-4.3...
Installed adjunctions-4.3
Configuring kan-extensions-5.0.2...
Building kan-extensions-5.0.2...
Installed kan-extensions-5.0.2
Configuring lens-4.15.4...
Building lens-4.15.4...
Warning: /tmp/pkgConf-lens-4.157407593551285228804.4: Unrecognized field
dynamic-library-dirs on line 122
Installed lens-4.15.4
Configuring json-autotype-1.0.18...
Building json-autotype-1.0.18...
Installed json-autotype-1.0.18
Configuring JuPyTer-notebook-0.1.0.0...
Building JuPyTer-notebook-0.1.0.0...
Failed to install JuPyTer-notebook-0.1.0.0
Build log ( /home/builder/.cabal/logs/JuPyTer-notebook-0.1.0.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-32012/JuPyTer-notebook-0.1.0.0'
Configuring JuPyTer-notebook-0.1.0.0...
Building JuPyTer-notebook-0.1.0.0...
Preprocessing library JuPyTer-notebook-0.1.0.0...
[1 of 1] Compiling Data.JuPyTer     ( src/Data/JuPyTer.hs, dist/build/Data/JuPyTer.o )

src/Data/JuPyTer.hs:12:1: error:
    Failed to load interface for ‘Data.ByteString.Lazy.Char8’
    It is a member of the hidden package ‘bytestring-0.10.8.1’.
    Perhaps you need to add ‘bytestring’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

src/Data/JuPyTer.hs:17:1: error:
    Failed to load interface for ‘Data.Aeson’
    It is a member of the hidden package ‘aeson-1.2.3.0’.
    Perhaps you need to add ‘aeson’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

src/Data/JuPyTer.hs:21:1: error:
    Failed to load interface for ‘Data.Text’
    It is a member of the hidden package ‘text-1.2.2.2’.
    Perhaps you need to add ‘text’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

src/Data/JuPyTer.hs:22:1: error:
    Failed to load interface for ‘Data.Text’
    It is a member of the hidden package ‘text-1.2.2.2’.
    Perhaps you need to add ‘text’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.
cabal: Leaving directory '/tmp/cabal-tmp-32012/JuPyTer-notebook-0.1.0.0'
cabal: Error: some packages failed to install:
JuPyTer-notebook-0.1.0.0 failed during the building phase. The exception was:
ExitFailure 1