The KiCS package

[Tags:library, program]

This package builds the Curry to Haskell compiler. Note, that you need a functional curry module Prelude.curry to get started. The standard version of that file is contained in the package KiCS-libraries.

Properties

Versions 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.9.0, 0.9.1, 0.9.2, 0.9.3
Dependencies base (==4.1.*), containers, curry-base (>=0.2.4), directory, filepath, haskell98, mtl, old-time, syb [details]
License OtherLicense
Author Bernd Braßel
Maintainer Bernd Braßel
Stability experimental
Category Compiler
Home page http://curry-language.org
Uploaded Fri Oct 9 15:16:21 UTC 2009 by BerndBrassel
Distributions NixOS:0.9.3
Downloads 2816 total (65 in the last 30 days)
Votes
0 []
Status Docs not available [build log]
All reported builds failed as of 2015-12-08 [all 5 reports]

Modules

  • Curry
    • Compiler
      • Curry.Compiler.Config
      • Curry.Compiler.CurryToHaskell
      • Curry.Compiler.Names
      • Curry.Compiler.SafeCalls
      • Curry.Compiler.ShowFlatCurry
    • Curry.RunTimeSystem
      • Curry.RunTimeSystem.BaseCurry
      • Curry.RunTimeSystem.Store

Downloads

Maintainer's Corner

For package maintainers and hackage trustees