The NTRU package

[maintain]
Warnings:

A Haskell implementation of the NTRU cryptographic system, following the IEEE Standard Specification for Public Key Crpytographic Techniques Based on Hard Problems over Lattices (IEEE Std 1363.1-2008)


[Skip to ReadMe]

Properties

Versions0.1.0.0, 1.0.0.0, 1.0.0.0, 1.0.0.1
Dependenciesarithmoi (==0.4.*), base (==4.6.*), bytestring (==0.10.*), containers (==0.5.*), crypto-api (==0.13.*), polynomial (==0.6.*), random (==1.0.*), SHA (==1.6.*), split (==0.2.*) [details]
LicenseBSD3
Copyright2014, CyberPoint International, LLC
AuthorTheo Levine, Tom Cornelius, Elizabeth Hughes, CyberPoint International LLC.
Maintaineropensource@cyberpointllc.com
CategoryCryptography, Math
UploadedFri Aug 22 15:18:17 UTC 2014 by mikewest

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for NTRU-1.0.0.0

This is a Haskell Implementation of the NTRU Cryptographic library, following the IEEE Standard Specification (IEEE Std 1363.1-2008).

You can build it by running:

cabal install NTRU

or by downloading it, and then running:

cabal configure
cabal build
cabal install 
You can ignore the warnings from the build.
You may need to install some dependencies, such as llvm.

##Please contact julrich@cyberpointllc.com with any questions.