Build #3 for Plot-ho-matic-0.12.2.3

[all reports]

Package Plot-ho-matic-0.12.2.3
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2018-12-15 00:01:35.518627618 UTC
Compiler ghc-8.6.1
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: Plot-ho-matic-0.12.2.3 (user goal)
[__1] trying: lens-4.17 (dependency of Plot-ho-matic)
[__2] trying: template-haskell-2.14.0.0/installed-2.1... (dependency of lens)
[__3] trying: base-4.12.0.0/installed-4.1... (dependency of Plot-ho-matic)
[__4] next goal: Chart-cairo (dependency of Plot-ho-matic)
[__4] rejecting: Chart-cairo-1.9, Chart-cairo-1.8.3 (conflict: lens==4.17,
Chart-cairo => lens>=3.9 && <4.17)
[__4] rejecting: Chart-cairo-1.8.2, Chart-cairo-1.8.1 (conflict: lens==4.17,
Chart-cairo => lens>=3.9 && <4.16)
[__4] rejecting: Chart-cairo-1.8, Chart-cairo-1.7.1 (conflict: lens==4.17,
Chart-cairo => lens>=3.9 && <4.15)
[__4] rejecting: Chart-cairo-1.7, Chart-cairo-1.6, Chart-cairo-1.5.4
(conflict: lens==4.17, Chart-cairo => lens>=3.9 && <4.14)
[__4] rejecting: Chart-cairo-1.5.1 (conflict: lens==4.17, Chart-cairo =>
lens>=3.9 && <4.13)
[__4] rejecting: Chart-cairo-1.5 (conflict: lens==4.17, Chart-cairo =>
lens>=3.9 && <4.12)
[__4] rejecting: Chart-cairo-1.4 (conflict: lens==4.17, Chart-cairo =>
lens>=3.9 && <4.10)
[__4] rejecting: Chart-cairo-1.3.3 (conflict: lens==4.17, Chart-cairo =>
lens>=3.9 && <4.8)
[__4] rejecting: Chart-cairo-1.3.2 (conflict: lens==4.17, Chart-cairo =>
lens>=3.9 && <4.7)
[__4] rejecting: Chart-cairo-1.3.1 (conflict: lens==4.17, Chart-cairo =>
lens>=3.9 && <4.5)
[__4] rejecting: Chart-cairo-1.3, Chart-cairo-1.2.4 (conflict: lens==4.17,
Chart-cairo => lens>=3.9 && <4.4)
[__4] rejecting: Chart-cairo-1.2.3 (conflict: lens==4.17, Chart-cairo =>
lens>=3.9 && <4.3)
[__4] rejecting: Chart-cairo-1.2.2 (conflict: lens==4.17, Chart-cairo =>
lens>=3.9 && <4.2)
[__4] rejecting: Chart-cairo-1.2, Chart-cairo-1.1 (conflict: lens==4.17,
Chart-cairo => lens>=3.9 && <3.11)
[__4] rejecting: Chart-cairo-1.0 (conflict: Plot-ho-matic => Chart-cairo>=1.1)
[__4] fail (backjumping, conflict set: Chart-cairo, Plot-ho-matic, lens)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: lens, Chart-cairo, template-haskell,
Plot-ho-matic, base