The SafeSemaphore package

[Tags:bsd3, library, test]

This provides a much safer semaphore than the QSem in base. Performance has not been compared. In the source is a tests/TestKillSem.hs executable (run by cabal test) that shows the problem with QSem.

Properties

Versions 0.4, 0.4.1, 0.5.0, 0.6.0, 0.7.0, 0.9.0, 0.10.0, 0.10.1
Dependencies base (<4.7) [details]
License BSD3
Author Chris Kuklewicz <haskell@list.mightyreason.com>
Maintainer Chris Kuklewicz <haskell@list.mightyreason.com>
Stability Unknown
Category Concurrency
Home page http://hackage.haskell.org/package/SafeSemaphore
Uploaded Wed Apr 13 10:34:40 UTC 2011 by ChrisKuklewicz
Updated Fri Jan 9 16:17:20 UTC 2015 by HerbertValerioRiedel to revision 1
Distributions Arch:0.10.1, Debian:0.10.1, Fedora:0.10.1, FreeBSD:0.10.1, LTSHaskell:0.10.1, NixOS:0.10.1, Stackage:0.10.1, Tumbleweed:0.10.1
Downloads 12516 total (66 in the last 30 days)
Votes
0 []
Status Docs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees