Build #3 for affine-0.1.1.0

[all reports]

Package affine-0.1.1.0
Install DependencyFailed affine-0.1.1.0
Docs NotTried
Tests NotTried
Time submitted 2018-05-17 08:44:13.732875433 UTC
Compiler ghc-8.2.2
OS linux
Arch x86_64
Dependencies alg-0.2.5.0, base-4.10.1.0
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring util-0.1.10.1...
Building util-0.1.10.1...
Installed util-0.1.10.1
Configuring alg-0.2.5.0...
Building alg-0.2.5.0...
Failed to install alg-0.2.5.0
Build log ( /home/builder/.cabal/logs/ghc-8.2.2/alg-0.2.5.0-G2n6O2D9k9m3NMiURqYhup.log ):
cabal: Entering directory '/tmp/cabal-tmp-19667/alg-0.2.5.0'
Configuring alg-0.2.5.0...
Preprocessing library for alg-0.2.5.0..
Building library for alg-0.2.5.0..
[1 of 3] Compiling Algebra          ( Algebra.hs, dist/build/Algebra.o )

Algebra.hs:121:21: error:
    • Could not deduce (Semigroup b) arising from a use of ‘<>’
      from the context: Group b
        bound by the type signature for:
                   commuteWith :: forall b a. Group b => (a -> a -> b) -> a -> a -> b
        at Algebra.hs:120:1-54
      Possible fix:
        add (Semigroup b) to the context of
          the type signature for:
            commuteWith :: forall b a. Group b => (a -> a -> b) -> a -> a -> b
    • In the expression: f x y <> invert (f y x)
      In an equation for ‘commuteWith’:
          commuteWith f x y = f x y <> invert (f y x)
    |
121 | commuteWith f x y = f x y <> invert (f y x)
    |                     ^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-19667/alg-0.2.5.0'
cabal: Error: some packages failed to install:
affine-0.1.1.0-GzVqIBvqg6Q7b4hBd00zXO depends on affine-0.1.1.0 which failed
to install.
alg-0.2.5.0-G2n6O2D9k9m3NMiURqYhup failed during the building phase. The
exception was:
ExitFailure 1