Build #1 for armada-0.1

[all reports]

Package armada-0.1
Install DependencyFailed OpenGLRaw-1.4.0.0
Docs NotTried
Tests NotTried
Time submitted unknown
Compiler ghc-7.6.3
OS linux
Arch x86_64
Dependencies stm-2.4.2, mtl-2.1.2, base-4.6.0.1, OpenGL-2.9.1.0, GLUT-2.5.0.2
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring OpenGLRaw-1.4.0.0...
cabal: Missing dependency on a foreign library:
* Missing C library: GL
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
Failed to install OpenGLRaw-1.4.0.0
Configuring stm-2.4.2...
Building stm-2.4.2...
Preprocessing library stm-2.4.2...
[ 1 of 10] Compiling Control.Sequential.STM ( Control/Sequential/STM.hs, dist/build/Control/Sequential/STM.o )
[ 2 of 10] Compiling Control.Concurrent.STM.TBQueue ( Control/Concurrent/STM/TBQueue.hs, dist/build/Control/Concurrent/STM/TBQueue.o )
[ 3 of 10] Compiling Control.Concurrent.STM.TQueue ( Control/Concurrent/STM/TQueue.hs, dist/build/Control/Concurrent/STM/TQueue.o )
[ 4 of 10] Compiling Control.Concurrent.STM.TChan ( Control/Concurrent/STM/TChan.hs, dist/build/Control/Concurrent/STM/TChan.o )
[ 5 of 10] Compiling Control.Concurrent.STM.TMVar ( Control/Concurrent/STM/TMVar.hs, dist/build/Control/Concurrent/STM/TMVar.o )
[ 6 of 10] Compiling Control.Concurrent.STM.TVar ( Control/Concurrent/STM/TVar.hs, dist/build/Control/Concurrent/STM/TVar.o )
[ 7 of 10] Compiling Control.Concurrent.STM.TArray ( Control/Concurrent/STM/TArray.hs, dist/build/Control/Concurrent/STM/TArray.o )
[ 8 of 10] Compiling Control.Monad.STM ( Control/Monad/STM.hs, dist/build/Control/Monad/STM.o )
[ 9 of 10] Compiling Control.Concurrent.STM ( Control/Concurrent/STM.hs, dist/build/Control/Concurrent/STM.o )
[10 of 10] Compiling Control.Concurrent.STM.TSem ( Control/Concurrent/STM/TSem.hs, dist/build/Control/Concurrent/STM/TSem.o )
In-place registering stm-2.4.2...
Running Haddock for stm-2.4.2...
Running hscolour for stm-2.4.2...
Preprocessing library stm-2.4.2...
Preprocessing library stm-2.4.2...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: rts-1.0
Haddock coverage:
   0% (  0 / 11) in 'Control.Sequential.STM'
 100% ( 12 / 12) in 'Control.Concurrent.STM.TBQueue'
 100% ( 12 / 12) in 'Control.Concurrent.STM.TQueue'
 100% ( 18 / 18) in 'Control.Concurrent.STM.TChan'
 100% ( 15 / 15) in 'Control.Concurrent.STM.TMVar'
 100% ( 12 / 12) in 'Control.Concurrent.STM.TVar'
 100% (  2 /  2) in 'Control.Concurrent.STM.TArray'
  90% (  9 / 10) in 'Control.Monad.STM'
 100% (  8 /  8) in 'Control.Concurrent.STM'
  40% (  2 /  5) in 'Control.Concurrent.STM.TSem'
Documentation created: dist/doc/html/stm/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/stm-2.4.2/ghc-7.6.3
Registering stm-2.4.2...
Installed stm-2.4.2
cabal: Error: some packages failed to install:
GLURaw-1.4.0.0 depends on OpenGLRaw-1.4.0.0 which failed to install.
GLUT-2.5.0.2 depends on OpenGLRaw-1.4.0.0 which failed to install.
OpenGL-2.9.1.0 depends on OpenGLRaw-1.4.0.0 which failed to install.
OpenGLRaw-1.4.0.0 failed during the configure step. The exception was:
ExitFailure 1
armada-0.1 depends on OpenGLRaw-1.4.0.0 which failed to install.