Build #3 for ats-pkg-3.2.4.5

[all reports]

Package ats-pkg-3.2.4.5
Install DependencyFailed ats-pkg-3.2.4.5
Docs NotTried
Tests NotTried
Time submitted 2019-01-12 23:40:34.091698856 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies Cabal-2.4.0.1, ansi-wl-pprint-0.6.8.2, base-4.12.0.0, bytestring-0.10.8.2, bzlib-0.5.0.5, containers-0.6.0.1, dependency-1.2.0.3, dhall-1.20.1, file-embed-0.0.11, filemanip-0.3.6.3, http-client-0.6.0, http-client-tls-0.3.5.3, lzma-0.0.0.3, mtl-2.2.2, parallel-io-0.3.3, process-1.6.3.0, shake-0.17.4, shake-ats-1.10.2.0, shake-c-0.4.0.0, shake-ext-3.1.0.0, tar-0.5.1.0, text-1.2.3.1, zip-archive-0.4, zlib-0.6.2, ansi-wl-pprint-0.6.8.2, base-4.12.0.0, binary-0.8.6.0, bytestring-0.10.8.2, composition-prelude-2.0.2.1, containers-0.6.0.1, dhall-1.20.1, directory-1.3.3.0, filepath-1.4.2.1, http-client-0.6.0, http-client-tls-0.3.5.3, microlens-0.4.10, mtl-2.2.2, process-1.6.3.0, shake-0.17.4, text-1.2.3.1, unix-2.7.2.2, base-4.12.0.0, bytestring-0.10.8.2, cli-setup-0.2.0.5, dependency-1.2.0.3, directory-1.3.3.0, microlens-0.4.10, optparse-applicative-0.14.3.0, parallel-io-0.3.3, shake-0.17.4, shake-ats-1.10.2.0, temporary-1.3, text-1.2.3.1
Flags -development -eventlog -profile

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     Only-0.1
Starting     StateVar-1.1.1.1
Starting     Diff-0.3.4
Starting     base-compat-0.10.5
Building     Only-0.1
Building     Diff-0.3.4
Building     StateVar-1.1.1.1
Building     base-compat-0.10.5
Completed    Only-0.1
Starting     base-orphans-0.8
Completed    StateVar-1.1.1.1
Starting     basement-0.0.8
Building     base-orphans-0.8
Building     basement-0.0.8
Completed    Diff-0.3.4
Starting     blaze-builder-0.4.1.0
Building     blaze-builder-0.4.1.0
Completed    base-orphans-0.8
Starting     byteable-0.1.1
Building     byteable-0.1.1
Completed    byteable-0.1.1
Starting     bzlib-0.5.0.5
Failed to install bzlib-0.5.0.5
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/bzlib-0.5.0.5-8TMEZNLRAIMKxXCedq0SW1.log ):
cabal: Entering directory '/tmp/cabal-tmp-11599/bzlib-0.5.0.5'
Configuring bzlib-0.5.0.5...
cabal: Missing dependency on a foreign library:
* Missing (or bad) header file: bzlib.h
* Missing (or bad) C library: bz2
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.If the
library file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.
If the header file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.

cabal: Leaving directory '/tmp/cabal-tmp-11599/bzlib-0.5.0.5'
Starting     cabal-doctest-1.0.6
Completed    base-compat-0.10.5
Completed    blaze-builder-0.4.1.0
Building     cabal-doctest-1.0.6
Completed    cabal-doctest-1.0.6
Completed    basement-0.0.8
cabal: Error: some packages failed to install:
ats-pkg-3.2.4.5-6XJBOlEW4KA2kUgXoIUmj5 depends on ats-pkg-3.2.4.5 which failed
to install.
bzlib-0.5.0.5-8TMEZNLRAIMKxXCedq0SW1 failed during the configure step. The
exception was:
ExitFailure 1