The base-noprelude package

[maintain]

This package simplifies defining custom Preludes without having to use -XNoImplicitPrelude by re-exporting the full module-hierarchy of the base-4.3.0.0 package except for the Prelude module.

Each version of base-noprelude depends on a specific base-version and thus mirrors base's versioning (with the exception that base-noprelude needs to add an additional 5th version component in case of bug-fix releases).

See https://github.com/hvr/base-noprelude for more information.

Properties

Versions4.3.0.0, 4.3.0.0, 4.3.1.0, 4.5.0.0, 4.5.1.0, 4.6.0.0, 4.6.0.1, 4.7.0.0, 4.7.0.1, 4.7.0.2, 4.8.0.0, 4.8.1.0, 4.8.2.0, 4.9.0.0, 4.9.1.0
Dependenciesbase (==4.3.0.0) [details]
LicenseBSD3
AuthorHerbert Valerio Riedel
Maintainerhvr@gnu.org
CategoryDevelopment
Home pagehttps://github.com/hvr/base-noprelude
Bug trackerhttps://github.com/hvr/base-noprelude/issues
UploadedSat May 30 13:02:49 UTC 2015 by HerbertValerioRiedel

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees