Build #8 for bash-0.1.4

[all reports]

Package bash-0.1.4
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-23 07:54:23.645252 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies SHA-1.6.4.2, base-4.9.0.0, binary-0.8.3.0, bytestring-0.10.8.1, containers-0.5.7.1, hxt-regex-xmlschema-9.2.0.3, mtl-2.2.1, shell-escape-0.2.0
Flags split-base

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring hxt-charproperties-9.2.0.1...
Configuring SHA-1.6.4.2...
Building hxt-charproperties-9.2.0.1...
Building SHA-1.6.4.2...
Configuring mtl-2.2.1...
Installed hxt-charproperties-9.2.0.1
Building mtl-2.2.1...
Configuring primitive-0.6.1.0...
Installed SHA-1.6.4.2
Building primitive-0.6.1.0...
Configuring text-1.2.2.1...
Installed mtl-2.2.1
Building text-1.2.2.1...
Installed primitive-0.6.1.0
Configuring vector-0.11.0.0...
Building vector-0.11.0.0...
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Building parsec-3.1.11...
Installed parsec-3.1.11
Configuring hxt-regex-xmlschema-9.2.0.3...
Building hxt-regex-xmlschema-9.2.0.3...
Installed vector-0.11.0.0
Configuring shell-escape-0.2.0...
Installed hxt-regex-xmlschema-9.2.0.3
Building shell-escape-0.2.0...
Installed shell-escape-0.2.0
Configuring bash-0.1.4...
Building bash-0.1.4...
Failed to install bash-0.1.4
Build log ( /home/builder/.cabal/logs/bash-0.1.4.log ):
cabal: Entering directory '/tmp/cabal-tmp-27766/bash-0.1.4'
Configuring bash-0.1.4...
Building bash-0.1.4...
Preprocessing library bash-0.1.4...
[1 of 7] Compiling Language.Bash.Syntax ( Language/Bash/Syntax.hs, dist/build/Language/Bash/Syntax.o )
[2 of 7] Compiling Language.Bash.PrettyPrinter.State ( Language/Bash/PrettyPrinter/State.hs, dist/build/Language/Bash/PrettyPrinter/State.o )
[3 of 7] Compiling Language.Bash.PrettyPrinter ( Language/Bash/PrettyPrinter.hs, dist/build/Language/Bash/PrettyPrinter.o )

Language/Bash/PrettyPrinter.hs:163:33: error:
    Precedence parsing error
        cannot mix ‘cons’ [infixr 5] and ‘snoc’ [infixl 5] in the same infix expression

Language/Bash/PrettyPrinter.hs:169:33: error:
    Precedence parsing error
        cannot mix ‘cons’ [infixr 5] and ‘snoc’ [infixl 5] in the same infix expression
cabal: Leaving directory '/tmp/cabal-tmp-27766/bash-0.1.4'
cabal: Error: some packages failed to install:
bash-0.1.4 failed during the building phase. The exception was:
ExitFailure 1