Build #3 for beam-postgres-0.3.1.0

[all reports]

Package beam-postgres-0.3.1.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2018-04-13 22:12:20.201746411 UTC
Compiler ghc-8.2.2
OS linux
Arch x86_64
Dependencies aeson-1.2.4.0, base-4.10.1.0, beam-core-0.7.2.0, beam-migrate-0.3.1.0, bytestring-0.10.8.2, case-insensitive-1.2.0.10, conduit-1.3.0.2, free-5.0.1, hashable-1.2.6.1, haskell-src-exts-1.20.2, lifted-base-0.2.3.12, monad-control-1.0.2.3, mtl-2.2.1, network-uri-2.6.1.0, postgresql-libpq-0.9.4.1, postgresql-simple-0.5.3.0, scientific-0.3.5.2, text-1.2.2.2, time-1.8.0.2, unordered-containers-0.2.8.0, uuid-1.3.13, vector-0.12.0.1
Flags -werror

Build log

[view raw]

Resolving dependencies...
Configuring OneTuple-0.2.1...
Configuring base-compat-0.9.3...
Building OneTuple-0.2.1...
Building base-compat-0.9.3...
Installed OneTuple-0.2.1
Configuring base-orphans-0.7...
Building base-orphans-0.7...
Installed base-compat-0.9.3
Configuring bytestring-builder-0.10.8.1.0...
Building bytestring-builder-0.10.8.1.0...
Installed bytestring-builder-0.10.8.1.0
Configuring cabal-doctest-1.0.6...
Installed base-orphans-0.7
Configuring cryptohash-md5-0.11.100.1...
Building cabal-doctest-1.0.6...
Building cryptohash-md5-0.11.100.1...
Installed cryptohash-md5-0.11.100.1
Configuring cryptohash-sha1-0.11.100.1...
Installed cabal-doctest-1.0.6
Configuring dependent-sum-0.4...
Building cryptohash-sha1-0.11.100.1...
Building dependent-sum-0.4...
Installed cryptohash-sha1-0.11.100.1
Configuring dlist-0.8.0.4...
Installed dependent-sum-0.4
Configuring entropy-0.3.8...
Building dlist-0.8.0.4...
Installed dlist-0.8.0.4
Configuring finite-typelits-0.1.3.0...
Building entropy-0.3.8...
Building finite-typelits-0.1.3.0...
Installed entropy-0.3.8
Configuring microlens-0.4.9.1...
Installed finite-typelits-0.1.3.0
Configuring network-info-0.2.0.10...
Building microlens-0.4.9.1...
Building network-info-0.2.0.10...
Installed network-info-0.2.0.10
Configuring old-locale-1.0.0.7...
Installed microlens-0.4.9.1
Configuring polyparse-1.12...
Building old-locale-1.0.0.7...
Building polyparse-1.12...
Installed old-locale-1.0.0.7
Configuring postgresql-libpq-0.9.4.1...
Building postgresql-libpq-0.9.4.1...
Installed polyparse-1.12
Configuring pqueue-1.4.1.1...
Building pqueue-1.4.1.1...
Installed postgresql-libpq-0.9.4.1
Configuring semigroups-0.18.4...
Building semigroups-0.18.4...
Installed semigroups-0.18.4
Configuring th-abstraction-0.2.6.0...
Building th-abstraction-0.2.6.0...
Installed pqueue-1.4.1.1
Configuring time-locale-compat-0.1.1.4...
Building time-locale-compat-0.1.1.4...
Installed th-abstraction-0.2.6.0
Configuring transformers-compat-0.6.1.5...
Building transformers-compat-0.6.1.5...
Installed time-locale-compat-0.1.1.4
Configuring unliftio-core-0.1.1.0...
Building unliftio-core-0.1.1.0...
Installed unliftio-core-0.1.1.0
Configuring uuid-types-1.0.3...
Building uuid-types-1.0.3...
Installed transformers-compat-0.6.1.5
Configuring vector-algorithms-0.7.0.1...
Building vector-algorithms-0.7.0.1...
Installed uuid-types-1.0.3
Configuring indexed-list-literals-0.1.0.1...
Building indexed-list-literals-0.1.0.1...
Installed indexed-list-literals-0.1.0.1
Configuring dependent-map-0.2.4.0...
Building dependent-map-0.2.4.0...
Installed dependent-map-0.2.4.0
Configuring old-time-1.1.0.3...
Installed vector-algorithms-0.7.0.1
Configuring transformers-base-0.4.5.2...
Building transformers-base-0.4.5.2...
Building old-time-1.1.0.3...
Installed transformers-base-0.4.5.2
Configuring tagged-0.8.5...
Building tagged-0.8.5...
Installed old-time-1.1.0.3
Configuring exceptions-0.10.0...
Building exceptions-0.10.0...
Installed tagged-0.8.5
Configuring contravariant-1.4.1...
Building contravariant-1.4.1...
Installed exceptions-0.10.0
Configuring uuid-1.3.13...
Building uuid-1.3.13...
Installed contravariant-1.4.1
Configuring vector-sized-1.0.0.0...
Building vector-sized-1.0.0.0...
Installed uuid-1.3.13
Configuring mono-traversable-1.0.8.1...
Building mono-traversable-1.0.8.1...
Installed vector-sized-1.0.0.0
Configuring monad-control-1.0.2.3...
Building monad-control-1.0.2.3...
Installed monad-control-1.0.2.3
Configuring cpphs-1.20.8...
Building cpphs-1.20.8...
Installed mono-traversable-1.0.8.1
Configuring distributive-0.5.3...
Building distributive-0.5.3...
Installed cpphs-1.20.8
Configuring aeson-1.2.4.0...
Installed distributive-0.5.3
Configuring resourcet-1.2.1...
Building aeson-1.2.4.0...
Building resourcet-1.2.1...
Installed resourcet-1.2.1
Configuring lifted-base-0.2.3.12...
Building lifted-base-0.2.3.12...
Installed lifted-base-0.2.3.12
Configuring haskell-src-exts-1.20.2...
Building haskell-src-exts-1.20.2...
Installed aeson-1.2.4.0
Configuring comonad-5.0.3...
Building comonad-5.0.3...
Installed comonad-5.0.3
Configuring conduit-1.3.0.2...
Building conduit-1.3.0.2...
Installed conduit-1.3.0.2
Configuring postgresql-simple-0.5.3.0...
Building postgresql-simple-0.5.3.0...
Installed postgresql-simple-0.5.3.0
Configuring bifunctors-5.5.2...
Building bifunctors-5.5.2...
Installed bifunctors-5.5.2
Configuring semigroupoids-5.2.2...
Building semigroupoids-5.2.2...
Installed semigroupoids-5.2.2
Configuring profunctors-5.2.2...
Building profunctors-5.2.2...
Installed profunctors-5.2.2
Configuring free-5.0.1...
Building free-5.0.1...
Installed free-5.0.1
Configuring beam-core-0.7.2.0...
Building beam-core-0.7.2.0...
Installed haskell-src-exts-1.20.2
Installed beam-core-0.7.2.0
Configuring beam-migrate-0.3.1.0...
Building beam-migrate-0.3.1.0...
Installed beam-migrate-0.3.1.0
Configuring beam-postgres-0.3.1.0...
Building beam-postgres-0.3.1.0...
Failed to install beam-postgres-0.3.1.0
Build log ( /home/builder/.cabal/logs/ghc-8.2.2/beam-postgres-0.3.1.0-5xLdsGXagtN8f4fJAFz09U.log ):
cabal: Entering directory '/tmp/cabal-tmp-28610/beam-postgres-0.3.1.0'
Configuring beam-postgres-0.3.1.0...
Preprocessing library for beam-postgres-0.3.1.0..
Building library for beam-postgres-0.3.1.0..
[ 1 of 10] Compiling Database.Beam.Postgres.Syntax ( Database/Beam/Postgres/Syntax.hs, dist/build/Database/Beam/Postgres/Syntax.o )

Database/Beam/Postgres/Syntax.hs:620:10: error:
    • No instance for (Data.Semigroup.Semigroup
                         (CustomSqlSyntax PgExpressionSyntax))
        arising from the superclasses of an instance declaration
    • In the instance declaration for
        ‘IsCustomSqlSyntax PgExpressionSyntax’
    |
620 | instance IsCustomSqlSyntax PgExpressionSyntax where
    |          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-28610/beam-postgres-0.3.1.0'
cabal: Error: some packages failed to install:
beam-postgres-0.3.1.0-5xLdsGXagtN8f4fJAFz09U failed during the building phase.
The exception was:
ExitFailure 1