Build #3 for bench-show-0.2.2

[all reports]

Package bench-show-0.2.2
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2018-11-02 08:58:27.469292494 UTC
Compiler ghc-8.6.1
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: bench-show-0.2.2 (user goal)
[__1] trying: base-4.12.0.0/installed-4.1... (dependency of bench-show)
[__2] trying: Chart-diagrams-1.9 (dependency of bench-show)
[__3] next goal: lens (dependency of Chart-diagrams)
[__3] rejecting: lens-4.17 (conflict: Chart-diagrams => lens>=3.9 && <4.17)
[__3] trying: lens-4.16.1
[__4] next goal: template-haskell (dependency of lens)
[__4] rejecting: template-haskell-2.14.0.0/installed-2.1... (conflict: lens =>
template-haskell>=2.4 && <2.14)
[__4] rejecting: template-haskell-2.14.0.0, template-haskell-2.13.0.0,
template-haskell-2.12.0.0, template-haskell-2.11.1.0,
template-haskell-2.11.0.0, template-haskell-2.10.0.0,
template-haskell-2.9.0.0, template-haskell-2.8.0.0, template-haskell-2.7.0.0,
template-haskell-2.6.0.0, template-haskell-2.5.0.0, template-haskell-2.4.0.1,
template-haskell-2.4.0.0, template-haskell-2.3.0.1, template-haskell-2.3.0.0,
template-haskell-2.2.0.0 (constraint from non-upgradeable package requires
installed instance)
[__4] fail (backjumping, conflict set: lens, template-haskell)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: lens, template-haskell,
Chart-diagrams, base, bench-show