Build #2 for bisc-0.4.0.0

[all reports]

Package bisc-0.4.0.0
Install DependencyFailed bisc-0.4.0.0
Docs NotTried
Tests NotTried
Time submitted 2021-09-07 16:28:05.018745272 UTC
Compiler ghc-8.10.2
OS linux
Arch x86_64
Dependencies base-4.14.1.0, bytestring-0.10.10.0, configurator-0.3.0.0, data-default-0.7.1.1, directory-1.3.6.0, exceptions-0.10.4, filepath-1.4.2.1, leveldb-haskell-0.6.5, mtl-2.2.2, optparse-applicative-0.16.1.0, selda-0.5.1.0, selda-sqlite-0.1.7.1, text-1.2.3.2
Flags -static

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Starting     data-default-class-0.1.2.0
Starting     colour-2.3.6
Starting     dlist-1.0
Starting     hashable-1.3.3.0
Building     colour-2.3.6
Building     dlist-1.0
Building     data-default-class-0.1.2.0
Building     hashable-1.3.3.0
Completed    data-default-class-0.1.2.0
Starting     integer-logarithms-1.0.3.1
Building     integer-logarithms-1.0.3.1
Completed    integer-logarithms-1.0.3.1
Starting     old-locale-1.0.0.7
Completed    dlist-1.0
Starting     primitive-0.7.2.0
Completed    hashable-1.3.3.0
Starting     semigroups-0.19.2
Building     old-locale-1.0.0.7
Building     primitive-0.7.2.0
Building     semigroups-0.19.2
Completed    old-locale-1.0.0.7
Starting     splitmix-0.1.0.3
Completed    semigroups-0.19.2
Starting     transformers-compat-0.7
Building     splitmix-0.1.0.3
Building     transformers-compat-0.7
Completed    colour-2.3.6
Starting     unix-compat-0.5.3
Building     unix-compat-0.5.3
Completed    splitmix-0.1.0.3
Starting     unliftio-core-0.2.0.1
Building     unliftio-core-0.2.0.1
Completed    unix-compat-0.5.3
Starting     data-default-instances-containers-0.0.1
Building     data-default-instances-containers-0.0.1
Completed    transformers-compat-0.7
Starting     data-default-instances-dlist-0.0.1
Completed    unliftio-core-0.2.0.1
Starting     unordered-containers-0.2.14.0
Building     data-default-instances-dlist-0.0.1
Building     unordered-containers-0.2.14.0
Completed    data-default-instances-containers-0.0.1
Starting     data-default-instances-old-locale-0.0.1
Completed    data-default-instances-dlist-0.0.1
Starting     direct-sqlite-2.3.26
Building     data-default-instances-old-locale-0.0.1
Building     direct-sqlite-2.3.26
Completed    data-default-instances-old-locale-0.0.1
Starting     ansi-terminal-0.11
Building     ansi-terminal-0.11
Completed    ansi-terminal-0.11
Starting     random-1.2.0
Building     random-1.2.0
Completed    primitive-0.7.2.0
Starting     data-default-0.7.1.1
Building     data-default-0.7.1.1
Completed    data-default-0.7.1.1
Starting     ansi-wl-pprint-0.6.9
Building     ansi-wl-pprint-0.6.9
Completed    unordered-containers-0.2.14.0
Starting     scientific-0.3.7.0
Building     scientific-0.3.7.0
Completed    ansi-wl-pprint-0.6.9
Starting     resourcet-1.2.4.3
Building     resourcet-1.2.4.3
Completed    random-1.2.0
Starting     optparse-applicative-0.16.1.0
Building     optparse-applicative-0.16.1.0
Completed    resourcet-1.2.4.3
Starting     uuid-types-1.0.5
Completed    scientific-0.3.7.0
Starting     leveldb-haskell-0.6.5
Building     uuid-types-1.0.5
Failed to install leveldb-haskell-0.6.5
Build log ( /home/builder/.cabal/logs/ghc-8.10.2/leveldb-haskell-0.6.5-3vKcID9WR7zIQATHrqZ8vH.log ):
cabal: Entering directory '/tmp/cabal-tmp-5166/leveldb-haskell-0.6.5'
Configuring leveldb-haskell-0.6.5...
cabal: Missing dependency on a foreign library:
* Missing (or bad) C library: leveldb
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.If the
library file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.

cabal: Leaving directory '/tmp/cabal-tmp-5166/leveldb-haskell-0.6.5'
Starting     attoparsec-0.14.1
Building     attoparsec-0.14.1
Completed    uuid-types-1.0.5
Completed    optparse-applicative-0.16.1.0
Completed    direct-sqlite-2.3.26
Completed    attoparsec-0.14.1
cabal: Error: some packages failed to install:
bisc-0.4.0.0-IDn7bsX8brHjYWPiOd2Lz depends on bisc-0.4.0.0 which failed to
install.
leveldb-haskell-0.6.5-3vKcID9WR7zIQATHrqZ8vH failed during the configure step.
The exception was:
ExitFailure 1