Metadata revisions for cabal-install-2.0.0.1

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User Changes
-r3 Mon Dec 4 15:50:18 UTC 2017 HerbertValerioRiedel
  • Changed the executable 'cabal' component's library dependency on 'async' from

    >=2.0 && <3
    to
    >=2.0 && <2.2

  • Changed the executable 'cabal' component's library dependency on 'bytestring' from

    >=0.9 && <1
    to
    >=0.9 && <0.11

  • Changed the executable 'cabal' component's library dependency on 'mtl' from

    >=2.0 && <3
    to
    >=2.0 && <2.3

  • Changed the executable 'cabal' component's library dependency on 'stm' from

    >=2.0 && <3
    to
    >=2.0 && <2.5

-r2 Mon Dec 4 15:46:33 UTC 2017 MikhailGlushenkov
  • Changed the executable 'cabal' component's library dependency on 'Cabal' from

    >=2.0 && <2.1
    to
    >=2.0.1.0 && <2.1

  • Changed the executable 'cabal' component's library dependency on 'Cabal' from

    >=2.0 && <2.1
    to
    >=2.0.1.0 && <2.1

-r1 Sat Dec 2 10:37:32 UTC 2017 HerbertValerioRiedel
  • Changed the executable 'cabal' component's library dependency on 'base' from

    >=4.5 && <5
    to
    >=4.5 && <4.11

  • Added 'other-extensions' in executable 'cabal' component

    MultiParamTypeClasses, Rank2Types, RankNTypes, ExistentialQuantification, ScopedTypeVariables, ImplicitParams, FlexibleContexts, FlexibleInstances, CPP, BangPatterns, NamedFieldPuns, GeneralizedNewtypeDeriving, TypeFamilies, StandaloneDeriving, RecordWildCards, OverloadedStrings, GADTs, DeriveDataTypeable, DeriveGeneric, ViewPatterns, LambdaCase, DeriveFunctor, DeriveTraversable, DeriveFoldable, NondecreasingIndentation, ConstraintKinds, NoMonoLocalBinds

-r0 Sat Dec 2 02:24:18 UTC 2017 MikhailGlushenkov