Metadata revisions for cabal-install-2.4.0.0

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User Changes
-r1 Mon Sep 17 09:52:36 UTC 2018 HerbertValerioRiedel
  • Changed the executable 'cabal' component's library dependency on 'Cabal' from

    ==2.4.*
    to
    >=2.4.0.1 && <2.5

  • Changed the executable 'cabal' component's library dependency on 'async' from

    >=2.0 && <3
    to
    >=2.0 && <2.3

  • Changed the executable 'cabal' component's library dependency on 'base' from

    >=4.6 && <5
    to
    >=4.8 && <4.13

  • Changed the executable 'cabal' component's library dependency on 'binary' from

    >=0.7 && <0.9
    to
    >=0.7.3 && <0.9

  • Changed the executable 'cabal' component's library dependency on 'bytestring' from

    >=0.10.2 && <1
    to
    >=0.10.6.0 && <0.11

  • Changed the executable 'cabal' component's library dependency on 'containers' from

    >=0.5 && <0.7
    to
    >=0.5.6.2 && <0.7

  • Changed the executable 'cabal' component's library dependency on 'deepseq' from

    >=1.3 && <1.5
    to
    >=1.4.1.1 && <1.5

  • Changed the executable 'cabal' component's library dependency on 'filepath' from

    >=1.3 && <1.5
    to
    >=1.4.0.0 && <1.5

  • Changed the executable 'cabal' component's library dependency on 'mtl' from

    >=2.0 && <3
    to
    >=2.0 && <2.3

  • Changed the executable 'cabal' component's library dependency on 'process' from

    >=1.1.0.2 && <1.7
    to
    >=1.2.3.0 && <1.7

  • Changed the executable 'cabal' component's library dependency on 'stm' from

    >=2.0 && <3
    to
    >=2.0 && <2.6

  • Changed the executable 'cabal' component's library dependency on 'time' from

    >=1.4 && <1.10
    to
    >=1.5.0.1 && <1.10

  • Changed the executable 'cabal' component's library dependency on 'unix' from

    >=2.5 && <2.9
    to
    >=2.5 && <2.8

-r0 Mon Sep 17 05:47:46 UTC 2018 MikhailGlushenkov