cabal-lenses: Lenses and traversals for the Cabal library.

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain]

Lenses and traversals (compatible with the lens library) for the Cabal library.


[Skip to ReadMe]

Properties

Versions0.1, 0.2, 0.3, 0.3.1, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.4.8, 0.4.9, 0.5.0, 0.6.0, 0.6.0, 0.7.0
Change logCHANGELOG
Dependenciesbase (>=3 && <5), Cabal (>=2.0.0.2 && <2.1), either (>=4.1.1 && <4.5), lens (>=4.0.1 && <4.16), strict (>=0.3.2 && <0.4), system-fileio (>=0.3.12 && <0.4), system-filepath (>=0.4.9 && <0.5), text (>=1.1.0.1 && <1.3), transformers (>=0.3.0.0 && <0.6), unordered-containers (>=0.2.3.3 && <0.3) [details]
LicenseBSD-3-Clause
AuthorDaniel Trstenjak
Maintainerdaniel.trstenjak@gmail.com
CategoryUtils, Development
Source repositoryhead: git clone https://github.com/dan-t/cabal-lenses
UploadedSun Dec 24 22:41:24 UTC 2017 by DanielTrstenjak

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees


Readme for cabal-lenses-0.6.0

[back to package description]

cabal-lenses

Lenses and traversals (compatible with the lens library) for the Cabal library.