cabal-parsers: Utilities to work with cabal-install files

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain]

This module provides (non-complete) parsers to work with cabal.project and cabal.config files.

The feature set is mainly motivated by the needs of haskell-ci package.

Properties

Version0.1
Change logNone available
Dependenciesaeson (>=1.4.6.0 && <1.5), base (>=4.10 && <4.14), base16-bytestring (>=0.1.1.6 && <0.2), bifunctors (>=5.5.4 && <5.6), binary (>=0.8.5 && <0.9), binary-instances (>=1 && <1.1), bytestring (>=0.10.8.1 && <0.11), Cabal (>=3.0.0.0 && <3.1), containers (>=0.5.7.1 && <0.6 || >=0.6.0.1 && <0.7), cryptohash-sha256 (>=0.11.101.0 && <0.12), directory (>=1.3.0.0 && <1.4), filepath (>=1.4.1.1 && <1.5), lukko (>=0.1.1 && <0.2), network-uri (>=2.6.1.0 && <2.7), parsec (>=3.1.13.0 && <3.2), pretty (>=1.1.3.3 && <1.2), tar (>=0.5.1.1 && <0.6), text (>=1.2.3.0 && <1.3), time (>=1.8.0.2 && <1.9 || >=1.9.3 && <1.10), transformers (>=0.5.2.0 && <0.6) [details]
LicenseGPL-2.0-or-later AND BSD-3-Clause[multiple license files]
AuthorHerbert Valerio Riedel, Oleg Grenrus
Maintainerhvr@gnu.org
CategoryDevelopment
Home pagehttps://haskell-ci.rtfd.org/
Bug trackerhttps://github.com/haskell-CI/haskell-ci/issues
Source repositoryhead: git clone https://github.com/haskell-CI/haskell-ci.git
UploadedThu Nov 14 11:46:32 UTC 2019 by phadej

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees