Build #5 for cabal-rpm-0.8.0

[all reports]

Package cabal-rpm-0.8.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2015-11-16 01:25:26.522403 UTC
Compiler ghc-7.10.2
OS linux
Arch x86_64
Dependencies unix-2.7.1.0, time-1.5.0.1, process-1.2.3.0, old-locale-1.0.0.7, filepath-1.4.0.0, directory-1.2.2.0, base-4.8.1.0, Cabal-1.22.4.0
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring old-locale-1.0.0.7...
Building old-locale-1.0.0.7...
Preprocessing library old-locale-1.0.0.7...
[1 of 1] Compiling System.Locale    ( System/Locale.hs, dist/build/System/Locale.o )
In-place registering old-locale-1.0.0.7...
Running Haddock for old-locale-1.0.0.7...
Running hscolour for old-locale-1.0.0.7...
Preprocessing library old-locale-1.0.0.7...
Preprocessing library old-locale-1.0.0.7...
Haddock coverage:
  60% (  3 /  5) in 'System.Locale'
  Missing documentation for:
    TimeLocale (System/Locale.hs:36)
    defaultTimeLocale (System/Locale.hs:49)
Documentation created: dist/doc/html/old-locale/index.html,
dist/doc/html/old-locale/old-locale.txt
Creating package registration file:
/tmp/pkgConf-old-locale-1.0.0278722862233665123.7
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-7.10.2/old-locale-1.0.0.7-D6X1KPq5Sui5XjrHMwvFwK
Registering old-locale-1.0.0.7...
Installed old-locale-1.0.0.7
Configuring cabal-rpm-0.8.0...
Building cabal-rpm-0.8.0...
Preprocessing executable 'cblrpm' for cabal-rpm-0.8.0...
[1 of 6] Compiling Paths_cabal_rpm  ( dist/build/autogen/Paths_cabal_rpm.hs, dist/build/cblrpm/cblrpm-tmp/Paths_cabal_rpm.o )
[2 of 6] Compiling Distribution.Package.Rpm.Utils ( src/Distribution/Package/Rpm/Utils.hs, dist/build/cblrpm/cblrpm-tmp/Distribution/Package/Rpm/Utils.o )
[3 of 6] Compiling Distribution.Package.Rpm.Setup ( src/Distribution/Package/Rpm/Setup.hs, dist/build/cblrpm/cblrpm-tmp/Distribution/Package/Rpm/Setup.o )
[4 of 6] Compiling Distribution.Package.Rpm ( src/Distribution/Package/Rpm.hs, dist/build/cblrpm/cblrpm-tmp/Distribution/Package/Rpm.o )

src/Distribution/Package/Rpm.hs:310:22:
    Not in scope: ‘licenseFile’
    Perhaps you meant ‘licenseFiles’ (imported from Distribution.PackageDescription)

src/Distribution/Package/Rpm.hs:311:26:
    Not in scope: ‘licenseFile’
    Perhaps you meant ‘licenseFiles’ (imported from Distribution.PackageDescription)

src/Distribution/Package/Rpm.hs:328:24:
    Not in scope: ‘licenseFile’
    Perhaps you meant ‘licenseFiles’ (imported from Distribution.PackageDescription)

src/Distribution/Package/Rpm.hs:353:14:
    Not in scope: ‘licenseFile’
    Perhaps you meant ‘licenseFiles’ (imported from Distribution.PackageDescription)
Failed to install cabal-rpm-0.8.0
cabal: Error: some packages failed to install:
cabal-rpm-0.8.0 failed during the building phase. The exception was:
ExitFailure 1