Build #8 for chp-1.7.0

[all reports]

Package chp-1.7.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-30 22:41:36.769773 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies HUnit-1.5.0.0, QuickCheck-2.9.2, base-4.9.0.0, containers-0.5.7.1, extensible-exceptions-0.1.1.4, mtl-2.2.1, parallel-3.2.1.0, pretty-1.1.3.3, stm-2.4.4.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring call-stack-0.1.0...
Configuring extensible-exceptions-0.1.1.4...
Building call-stack-0.1.0...
Building extensible-exceptions-0.1.1.4...
Installed extensible-exceptions-0.1.1.4
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Configuring parallel-3.2.1.0...
Installed call-stack-0.1.0
Building parallel-3.2.1.0...
Configuring random-1.1...
Installed parallel-3.2.1.0
Building random-1.1...
Configuring primitive-0.6.2.0...
Installed mtl-2.2.1
Building primitive-0.6.2.0...
Configuring stm-2.4.4.1...
Installed random-1.1
Building stm-2.4.4.1...
Installed stm-2.4.4.1
Configuring HUnit-1.5.0.0...
Building HUnit-1.5.0.0...
Installed primitive-0.6.2.0
Configuring tf-random-0.5...
Building tf-random-0.5...
Installed HUnit-1.5.0.0
Installed tf-random-0.5
Configuring QuickCheck-2.9.2...
Building QuickCheck-2.9.2...
Installed QuickCheck-2.9.2
Configuring chp-1.7.0...
Building chp-1.7.0...
Failed to install chp-1.7.0
Build log ( /home/builder/.cabal/logs/chp-1.7.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-7523/chp-1.7.0'
Warning: chp.cabal: A package using 'cabal-version: >=1.2.3' must use section
syntax. See the Cabal user guide for details.
Configuring chp-1.7.0...
Building chp-1.7.0...
Preprocessing library chp-1.7.0...
[ 1 of 37] Compiling Control.Concurrent.CHP.ProcessId ( Control/Concurrent/CHP/ProcessId.hs, dist/build/Control/Concurrent/CHP/ProcessId.o )
[ 2 of 37] Compiling Control.Concurrent.CHP.Poison ( Control/Concurrent/CHP/Poison.hs, dist/build/Control/Concurrent/CHP/Poison.o )

Control/Concurrent/CHP/Poison.hs:41:10: error:
    • No instance for (Applicative WithPoison)
        arising from the superclasses of an instance declaration
    • In the instance declaration for ‘Monad WithPoison’
cabal: Leaving directory '/tmp/cabal-tmp-7523/chp-1.7.0'
cabal: Error: some packages failed to install:
chp-1.7.0 failed during the building phase. The exception was:
ExitFailure 1