Build #3 for clckwrks-plugin-ircbot-0.6.17.5

[all reports]

Package clckwrks-plugin-ircbot-0.6.17.5
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2019-05-26 20:09:34.586595019 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: clckwrks-plugin-ircbot-0.6.17.5 (user goal)
[__1] trying: ircbot-0.6.5.3 (dependency of clckwrks-plugin-ircbot)
[__2] next goal: stm (dependency of ircbot)
[__2] rejecting: stm-2.5.0.0/installed-2.5..., stm-2.5.0.0 (conflict: ircbot
=> stm>=2.2 && <2.5)
[__2] trying: stm-2.4.5.1
[__3] next goal: base (dependency of clckwrks-plugin-ircbot)
[__3] rejecting: base-4.12.0.0/installed-4.1... (conflict: stm => base>=4.3 &&
<4.12)
[__3] rejecting: base-4.12.0.0, base-4.11.1.0, base-4.11.0.0, base-4.10.1.0,
base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0,
base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1,
base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0,
base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0,
base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from
non-upgradeable package requires installed instance)
[__3] fail (backjumping, conflict set: base, clckwrks-plugin-ircbot, stm)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: ircbot, stm, base,
clckwrks-plugin-ircbot