Build #3 for colorless-2.2.6

[all reports]

Package colorless-2.2.6
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-10-06 21:02:26.013891213 UTC
Compiler ghc-8.0.2
OS linux
Arch x86_64
Dependencies aeson-1.2.2.0, base-4.9.1.0, bytestring-0.10.8.1, containers-0.5.7.1, errors-2.2.2, exceptions-0.8.3, lifted-async-0.9.3, monad-control-1.0.2.2, monad-logger-0.3.25.1, mtl-2.2.1, random-1.1, scientific-0.3.5.2, text-1.2.2.2, text-conversions-0.3.0, unordered-containers-0.2.8.0, vector-0.12.0.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring auto-update-0.1.4...
Configuring base-compat-0.9.3...
Building auto-update-0.1.4...
Building base-compat-0.9.3...
Configuring base16-bytestring-0.1.1.6...
Installed auto-update-0.1.4
Building base16-bytestring-0.1.1.6...
Configuring dlist-0.8.0.3...
Installed base-compat-0.9.3
Configuring base64-bytestring-1.0.0.1...
Installed base16-bytestring-0.1.1.6
Building dlist-0.8.0.3...
Building base64-bytestring-1.0.0.1...
Configuring easy-file-0.2.1...
Installed base64-bytestring-1.0.0.1
Installed dlist-0.8.0.3
Configuring integer-logarithms-1.0.2...
Building easy-file-0.2.1...
Building integer-logarithms-1.0.2...
Configuring mtl-2.2.1...
Installed integer-logarithms-1.0.2
Building mtl-2.2.1...
Configuring monad-loops-0.4.3...
Installed easy-file-0.2.1
Building monad-loops-0.4.3...
Configuring old-locale-1.0.0.7...
Installed monad-loops-0.4.3
Building old-locale-1.0.0.7...
Configuring primitive-0.6.2.0...
Installed old-locale-1.0.0.7
Configuring random-1.1...
Installed mtl-2.2.1
Building primitive-0.6.2.0...
Building random-1.1...
Configuring network-2.6.3.2...
Installed random-1.1
Building network-2.6.3.2...
Configuring stm-2.4.4.1...
Installed primitive-0.6.2.0
Building stm-2.4.4.1...
Configuring safe-0.3.15...
Installed stm-2.4.4.1
Building safe-0.3.15...
Configuring th-abstraction-0.2.6.0...
Installed safe-0.3.15
Building th-abstraction-0.2.6.0...
Configuring time-locale-compat-0.1.1.3...
Installed network-2.6.3.2
Building time-locale-compat-0.1.1.3...
Configuring text-1.2.2.2...
Installed time-locale-compat-0.1.1.3
Building text-1.2.2.2...
Configuring transformers-compat-0.5.1.4...
Installed th-abstraction-0.2.6.0
Building transformers-compat-0.5.1.4...
Configuring unexceptionalio-0.3.0...
Installed transformers-compat-0.5.1.4
Building unexceptionalio-0.3.0...
Configuring zlib-0.6.1.2...
Installed unexceptionalio-0.3.0
Building zlib-0.6.1.2...
Installed zlib-0.6.1.2
Configuring old-time-1.1.0.3...
Building old-time-1.1.0.3...
Configuring async-2.1.1.1...
Installed text-1.2.2.2
Configuring vector-0.12.0.1...
Installed old-time-1.1.0.3
Building async-2.1.1.1...
Building vector-0.12.0.1...
Configuring stm-chans-3.0.0.4...
Installed async-2.1.1.1
Building stm-chans-3.0.0.4...
Warning: /tmp/pkgConf-stm-chans-3.0.0959997301485560280.4: Unrecognized field
dynamic-library-dirs on line 24
Configuring exceptions-0.8.3...
Installed stm-chans-3.0.0.4
Building exceptions-0.8.3...
Configuring mmorph-1.1.0...
Installed exceptions-0.8.3
Building mmorph-1.1.0...
Configuring transformers-base-0.4.4...
Installed mmorph-1.1.0
Building transformers-base-0.4.4...
Configuring tagged-0.8.5...
Installed transformers-base-0.4.4
Building tagged-0.8.5...
Installed tagged-0.8.5
Configuring hashable-1.2.6.1...
Building hashable-1.2.6.1...
Configuring blaze-builder-0.4.0.2...
Installed hashable-1.2.6.1
Configuring unix-time-0.3.7...
Installed vector-0.12.0.1
Building blaze-builder-0.4.0.2...
Building unix-time-0.3.7...
Configuring errors-2.2.2...
Installed blaze-builder-0.4.0.2
Building errors-2.2.2...
Configuring monad-control-1.0.2.2...
Installed unix-time-0.3.7
Building monad-control-1.0.2.2...
Installed errors-2.2.2
Configuring constraints-0.9.1...
Configuring unordered-containers-0.2.8.0...
Installed monad-control-1.0.2.2
Building constraints-0.9.1...
Building unordered-containers-0.2.8.0...
Configuring uuid-types-1.0.3...
Installed constraints-0.9.1
Building uuid-types-1.0.3...
Configuring scientific-0.3.5.2...
Installed unordered-containers-0.2.8.0
Building scientific-0.3.5.2...
Configuring streaming-commons-0.1.18...
Installed uuid-types-1.0.3
Building streaming-commons-0.1.18...
Configuring fast-logger-2.4.10...
Installed scientific-0.3.5.2
Building fast-logger-2.4.10...
Configuring text-conversions-0.3.0...
Installed fast-logger-2.4.10
Building text-conversions-0.3.0...
Installed streaming-commons-0.1.18
Configuring lifted-base-0.2.3.11...
Building lifted-base-0.2.3.11...
Configuring attoparsec-0.13.2.0...
Installed text-conversions-0.3.0
Building attoparsec-0.13.2.0...
Installed lifted-base-0.2.3.11
Configuring resourcet-1.1.9...
Building resourcet-1.1.9...
Configuring lifted-async-0.9.3...
Installed resourcet-1.1.9
Building lifted-async-0.9.3...
Configuring conduit-1.2.12.1...
Installed attoparsec-0.13.2.0
Building conduit-1.2.12.1...
Installed lifted-async-0.9.3
Configuring aeson-1.2.2.0...
Building aeson-1.2.2.0...
Installed conduit-1.2.12.1
Configuring conduit-extra-1.1.17...
Building conduit-extra-1.1.17...
Installed conduit-extra-1.1.17
Configuring monad-logger-0.3.25.1...
Building monad-logger-0.3.25.1...
Installed monad-logger-0.3.25.1
Installed aeson-1.2.2.0
Configuring colorless-2.2.6...
Building colorless-2.2.6...
Failed to install colorless-2.2.6
Build log ( /home/builder/.cabal/logs/colorless-2.2.6.log ):
cabal: Entering directory '/tmp/cabal-tmp-9558/colorless-2.2.6'
Configuring colorless-2.2.6...
Building colorless-2.2.6...
Preprocessing library colorless-2.2.6...
[ 1 of 12] Compiling Colorless.Types  ( library/Colorless/Types.hs, dist/build/Colorless/Types.o )

library/Colorless/Types.hs:10:5: error:
    Ambiguous occurrence ‘Options’
    It could refer to either ‘Data.Aeson.Options’,
                             imported from ‘Data.Aeson’ at library/Colorless/Types.hs:24:1-17
                             (and originally defined in ‘aeson-1.2.2.0:Data.Aeson.Types.Internal’)
                          or ‘Colorless.Types.Options’,
                             defined at library/Colorless/Types.hs:142:1
cabal: Leaving directory '/tmp/cabal-tmp-9558/colorless-2.2.6'
cabal: Error: some packages failed to install:
colorless-2.2.6 failed during the building phase. The exception was:
ExitFailure 1