Build #8 for cpsa-2.1.0

[all reports]

Package cpsa-2.1.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-29 10:53:18.065338 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, containers-0.5.7.1, parallel-3.2.1.0, base-4.9.0.0, containers-0.5.7.1, base-4.9.0.0, containers-0.5.7.1, base-4.9.0.0, containers-0.5.7.1, base-4.9.0.0, containers-0.5.7.1, base-4.9.0.0, containers-0.5.7.1
Flags par

Build log

[view raw]

Resolving dependencies...
Configuring parallel-3.2.1.0...
Building parallel-3.2.1.0...
Installed parallel-3.2.1.0
Configuring cpsa-2.1.0...
Building cpsa-2.1.0...
Failed to install cpsa-2.1.0
Build log ( /home/builder/.cabal/logs/cpsa-2.1.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-14651/cpsa-2.1.0'
Configuring cpsa-2.1.0...
Building cpsa-2.1.0...
Preprocessing executable 'cpsa' for cpsa-2.1.0...
[ 1 of 18] Compiling Paths_cpsa       ( dist/build/autogen/Paths_cpsa.hs, dist/build/cpsa/cpsa-tmp/Paths_cpsa.o )
[ 2 of 18] Compiling CPSA.Lib.Utilities ( src/CPSA/Lib/Utilities.hs, dist/build/cpsa/cpsa-tmp/CPSA/Lib/Utilities.o )
[ 3 of 18] Compiling CPSA.Lib.SExpr   ( src/CPSA/Lib/SExpr.hs, dist/build/cpsa/cpsa-tmp/CPSA/Lib/SExpr.o )
[ 4 of 18] Compiling CPSA.Lib.Pretty  ( src/CPSA/Lib/Pretty.hs, dist/build/cpsa/cpsa-tmp/CPSA/Lib/Pretty.o )
[ 5 of 18] Compiling CPSA.Lib.Printer ( src/CPSA/Lib/Printer.hs, dist/build/cpsa/cpsa-tmp/CPSA/Lib/Printer.o )
[ 6 of 18] Compiling CPSA.Lib.Entry   ( src/CPSA/Lib/Entry.hs, dist/build/cpsa/cpsa-tmp/CPSA/Lib/Entry.o )

src/CPSA/Lib/Entry.hs:68:12: error:
    Variable not in scope:
      try
        :: IO (Maybe (SExpr Pos))
           -> IO (Either IOError (Maybe (SExpr Pos)))
cabal: Leaving directory '/tmp/cabal-tmp-14651/cpsa-2.1.0'
cabal: Error: some packages failed to install:
cpsa-2.1.0 failed during the building phase. The exception was:
ExitFailure 1