Build #3 for csg-0.1.0.6

[all reports]

Package csg-0.1.0.6
Install DependencyFailed csg-0.1.0.6
Docs NotTried
Tests NotTried
Time submitted 2019-01-18 14:50:15.50214004 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies QuickCheck-2.12.6.1, attoparsec-0.13.2.2, base-4.12.0.0, bytestring-0.10.8.2, containers-0.6.0.1, simple-vec3-0.4.0.10, strict-0.3.2, transformers-0.5.5.0, QuickCheck-2.12.6.1, base-4.12.0.0, gloss-1.13.0.1, gloss-raster-1.13.0.2, simple-vec3-0.4.0.10, strict-0.3.2, system-filepath-0.4.14, turtle-1.5.13
Flags -triples

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     StateVar-1.1.1.1
Starting     ObjectName-1.1.0.1
Starting     base-prelude-1.3
Starting     base-orphans-0.8
Building     StateVar-1.1.1.1
Building     base-prelude-1.3
Building     ObjectName-1.1.0.1
Building     base-orphans-0.8
Completed    ObjectName-1.1.0.1
Starting     bmp-1.2.6.3
Completed    base-orphans-0.8
Starting     cabal-doctest-1.0.6
Completed    StateVar-1.1.1.1
Starting     clock-0.7.2
Building     bmp-1.2.6.3
Building     cabal-doctest-1.0.6
Building     clock-0.7.2
Completed    clock-0.7.2
Starting     colour-2.3.4
Completed    cabal-doctest-1.0.6
Starting     data-default-class-0.1.2.0
Building     colour-2.3.4
Building     data-default-class-0.1.2.0
Completed    bmp-1.2.6.3
Starting     erf-2.0.0.0
Completed    base-prelude-1.3
Starting     fixed-0.2.1.1
Building     erf-2.0.0.0
Building     fixed-0.2.1.1
Completed    data-default-class-0.1.2.0
Starting     half-0.3
Building     half-0.3
Completed    erf-2.0.0.0
Starting     hashable-1.2.7.0
Completed    fixed-0.2.1.1
Starting     hostname-1.0
Building     hashable-1.2.7.0
Building     hostname-1.0
Completed    hostname-1.0
Starting     integer-logarithms-1.0.2.2
Completed    half-0.3
Starting     managed-1.0.6
Building     integer-logarithms-1.0.2.2
Building     managed-1.0.6
Completed    colour-2.3.4
Starting     optional-args-1.0.2
Building     optional-args-1.0.2
Completed    hashable-1.2.7.0
Starting     primitive-0.6.4.0
Completed    integer-logarithms-1.0.2.2
Starting     random-1.1
Completed    managed-1.0.6
Starting     semigroups-0.18.5
Building     primitive-0.6.4.0
Building     random-1.1
Building     semigroups-0.18.5
Completed    optional-args-1.0.2
Starting     strict-0.3.2
Building     strict-0.3.2
Completed    semigroups-0.18.5
Starting     system-filepath-0.4.14
Completed    strict-0.3.2
Starting     tagged-0.8.6
Completed    random-1.1
Starting     th-abstraction-0.2.10.0
Building     tagged-0.8.6
Building     th-abstraction-0.2.10.0
Building     system-filepath-0.4.14
Completed    tagged-0.8.6
Starting     transformers-compat-0.6.2
Building     transformers-compat-0.6.2
Completed    system-filepath-0.4.14
Starting     unix-compat-0.5.1
Completed    th-abstraction-0.2.10.0
Starting     contravariant-1.5
Building     unix-compat-0.5.1
Building     contravariant-1.5
Completed    transformers-compat-0.6.2
Starting     OpenGLRaw-3.3.2.0
Completed    unix-compat-0.5.1
Starting     ansi-terminal-0.8.2
Failed to install OpenGLRaw-3.3.2.0
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/OpenGLRaw-3.3.2.0-H7dnX9YQ3tNDJjlAIPrSiZ.log ):
cabal: Entering directory '/tmp/cabal-tmp-9121/OpenGLRaw-3.3.2.0'
Configuring OpenGLRaw-3.3.2.0...
cabal: Missing dependency on a foreign library:
* Missing (or bad) C library: GL
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.If the
library file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.

cabal: Leaving directory '/tmp/cabal-tmp-9121/OpenGLRaw-3.3.2.0'
Starting     unordered-containers-0.2.9.0
Building     ansi-terminal-0.8.2
Building     unordered-containers-0.2.9.0
Completed    contravariant-1.5
Completed    primitive-0.6.4.0
Completed    ansi-terminal-0.8.2
Completed    unordered-containers-0.2.9.0
cabal: Error: some packages failed to install:
GLURaw-2.0.0.4-3zLeh5KBSJKIKHgOKCg8vm depends on GLURaw-2.0.0.4 which failed
to install.
GLUT-2.7.0.14-19iLC1dvtamAzL5nrNFIav depends on GLUT-2.7.0.14 which failed to
install.
OpenGL-3.0.2.2-1Vj0mLgFBQSLv0NaPZWEIu depends on OpenGL-3.0.2.2 which failed
to install.
OpenGLRaw-3.3.2.0-H7dnX9YQ3tNDJjlAIPrSiZ failed during the configure step. The
exception was:
ExitFailure 1
csg-0.1.0.6-4qL6BHUSqKE6rQv2EnLLgg depends on csg-0.1.0.6 which failed to
install.
gloss-1.13.0.1-4b78OtnGh71eCuwHPriYf depends on gloss-1.13.0.1 which failed to
install.
gloss-raster-1.13.0.2-I1Kskgsg6HaKPDDCBRNfOA depends on gloss-raster-1.13.0.2
which failed to install.
gloss-rendering-1.13.0.2-HT6cbm8dYzDFBdsWoCrtsZ depends on
gloss-rendering-1.13.0.2 which failed to install.