The cublas package

[maintain]

This package provides FFI bindings to the NVIDIA CUDA CUBLAS and CUSPARSE linear algebra GPU BLAS implementations. The modules Foreign.CUDA.Cublas and Foreign.CUDA.Cusparse are probably the most useful.

Requires CUDA version 6.5.

If you have trouble installing this package, it may help to view the Github page: http://github.com/bmsherman/cublas

Properties

Versions0.2.0.0, 0.2.0.1, 0.2.0.2, 0.2.1.0, 0.2.1.0
Dependenciesbase (>=4.4 && <4.8), cuda (>=0.4.1 && <0.7), filepath (==1.3.*), language-c (>=0.4.2 && <0.5), storable-complex (>=0.2.1 && <0.3), template-haskell (>=2.7 && <2.10) [details]
LicenseBSD3
CopyrightCopyright (c) [2012..2014]. Trevor L. McDonell <tmcdonell@cse.unsw.edu.au>, Ben Sherman <benmsherman@gmail.com>
AuthorTrevor L. McDonell, Ben Sherman
MaintainerBen Sherman <benmsherman@gmail.com>
CategoryForeign
Home pagehttps://github.com/bmsherman/cublas
Source repositoryhead: git clone git://github.com/bmsherman/cublas.git
this: git clone git://github.com/bmsherman/cublas/releases/tag/0.2.1.0.git(tag 0.2.1.0)
UploadedWed Dec 17 16:09:46 UTC 2014 by bmsherman

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees