The data-interval package

[maintain]

Unlike the intervals package (http://hackage.haskell.org/package/intervals), this package provides both open and closed intervals and is intended to be used with Rational.

Changes in 0.5.0

Changes in 0.4.0


Properties

Versions0.1.0, 0.2.0, 0.3.0, 0.4.0, 0.5.0, 0.5.0, 0.6.0, 1.0.0, 1.0.1
Dependenciesbase (==4.*), deepseq, hashable (>=1.1.2.5 && <1.3), lattices (>=1.2.1.1)
LicenseBSD3
AuthorMasahiro Sakai (masahiro.sakai@gmail.com)
Maintainermasahiro.sakai@gmail.com
CategoryData, Math
Bug trackerhttps://github.com/msakai/data-interval/issues
Source repositoryhead: git clone git://github.com/msakai/data-interval.git
Upload dateSun Apr 6 09:58:04 UTC 2014
Uploaded byMasahiroSakai

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees