The database-migrate package

[ Tags: bsd3, database, library ] [ Propose Tags ]

A database versioning and migration library.

Note: This library is under heavy development, currently the PostgreSQL implementation is functional, but expected to change. It is intended that a type safe migration api, command line tools and MySql support be added before this library will be considered stable.

Properties

Versions 0.0.1, 0.0.2, 0.0.3, 0.1.0, 0.1.1, 0.1.2, 0.2.0
Dependencies base (>=3 && <5), bytestring (==0.9.*), cmdargs (>=0.9.3 && <1.0.0), containers (==0.4.*), database-migrate, directory (>=1.0 && <2.0), either (>=3.0.2 && <4.0), filepath (>=1.0 && <2.0), postgresql-simple (>=0.1 && <1.0), text (==0.11.*), time (>=1.0 && <2.0), transformers (>=0.2 && <0.4) [details]
License BSD3
Copyright (c) 2012 Mark Hibberd
Author Mark Hibberd <mark@hibberd.id.au>
Maintainer Mark Hibberd <mark@hibberd.id.au>
Category Database
Home page https://github.com/markhibberd/database-migrate
Bug tracker https://github.com/markhibberd/database-migrate/issues
Source repository head: git clone https://github.com/markhibberd/migrate.git
Uploaded Thu Aug 23 13:22:59 UTC 2012 by MarkHibberd
Distributions NixOS:0.2.0
Executables migrate
Downloads 1669 total (9 in the last 30 days)
Rating 0.0 (0 ratings) [clear rating]
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]
Hackage Matrix CI

Modules

[Index]

Flags

NameDescriptionDefaultType
small_base

Choose the new, split-up base package.

EnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees