debian: Modules for working with the Debian package system

[ bsd3, debian, library, program ] [ Propose Tags ]

This library includes modules covering some basic data types defined by the Debian policy manual - version numbers, control file syntax, etc.

Versions 1.0, 1.2, 1.2.1, 3.14, 3.17.1, 3.18.1, 3.21, 3.23, 3.31, 3.32, 3.33, 3.35, 3.40, 3.46, 3.47, 3.54, 3.55, 3.61, 3.64, 3.64.1, 3.65, 3.65.1, 3.66, 3.69, 3.69.1, 3.70, 3.70.1, 3.79.1, 3.79.2, 3.79.3, 3.79.4, 3.80.1, 3.81, 3.81.3, 3.83, 3.83.3, 3.83.3.1, 3.83.4, 3.83.4.1, 3.83.4.2, 3.84, 3.85, 3.85.2, 3.87, 3.87.1, 3.87.2, 3.88, 3.88.1, 3.89, 3.91, 3.91.1, 3.91.2, 3.92, 3.92.1, 3.93.2
Dependencies base (==4.*), bytestring, bzlib, Cabal (>=1.8), containers, directory, filepath, HaXml (>=1.20), HUnit, mtl, network (>=2.4), old-locale, parsec (>=2 && <4), pretty, pretty-class, process, process-extras, pureMD5, regex-compat, regex-tdfa, time, unix, Unixutils (>=1.50), utf8-string, zlib [details]
License BSD-3-Clause
Author David Fox <dsf@seereason.com>, Jeremy Shaw <jeremy@seereason.com>, Clifford Beshers <beshers@seereason.com>
Maintainer David Fox <dsf@seereason.com>
Category Debian
Home page http://src.seereason.com/haskell-debian-new
Source repo head: darcs get http://src.seereason.com/darcs/haskell-debian-new
Uploaded by DavidFox at Wed Oct 24 22:26:03 UTC 2012
Distributions Debian:3.89, NixOS:3.93.2
Executables apt-get-build-depends, debian-report, fakechanges
Downloads 19573 total (648 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs not available [build log]
All reported builds failed as of 2016-12-23 [all 8 reports]
Hackage Matrix CI

Modules

  • Debian
    • Apt
      • Debian.Apt.Dependencies
      • Debian.Apt.Index
      • Debian.Apt.Methods
      • Debian.Apt.Package
    • Debian.Changes
    • Debian.Control
      • Debian.Control.ByteString
      • Debian.Control.Common
      • Debian.Control.PrettyPrint
      • Debian.Control.String
    • Debian.Deb
    • Extra
      • Debian.Extra.Files
    • Debian.GenBuildDeps
    • Debian.Relation
      • Debian.Relation.ByteString
      • Debian.Relation.Common
      • Debian.Relation.String
    • Debian.Release
    • Debian.Report
    • Debian.Sources
    • Debian.Time
    • Debian.URI
    • Util
      • Debian.Util.FakeChanges
    • Debian.Version
      • Debian.Version.ByteString
      • Debian.Version.Common
      • Debian.Version.String

Flags

NameDescriptionDefaultType
cabal19

True if Cabal >= 1.9 is available

EnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees