Build #2 for dfinity-radix-tree-0.6.3

[all reports]

Package dfinity-radix-tree-0.6.3
Install DependencyFailed dfinity-radix-tree-0.6.3
Docs NotTried
Tests NotTried
Time submitted 2019-03-14 08:34:37.896404665 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies BoundedChan-1.0.3.0, base-4.12.0.0, base16-bytestring-0.1.1.6, bytestring-0.10.8.2, concurrent-extra-0.7.0.12, conduit-1.3.1.1, containers-0.6.0.1, cryptonite-0.25, data-default-class-0.1.2.0, deepseq-1.4.4.0, directory-1.3.3.0, dlist-0.8.0.5, hashtables-1.2.3.1, lens-simple-0.1.0.9, leveldb-haskell-0.6.5, lrucaching-0.3.3, memory-0.14.18, mtl-2.2.2, reducers-3.12.3, resourcet-1.2.2, serialise-0.2.1.0, temporary-1.3, transformers-0.5.5.0, base-4.12.0.0, base16-bytestring-0.1.1.6, bytestring-0.10.8.2, containers-0.6.0.1
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     BoundedChan-1.0.3.0
Starting     StateVar-1.1.1.1
Starting     base-orphans-0.8
Starting     base-compat-0.10.5
Building     StateVar-1.1.1.1
Building     base-orphans-0.8
Building     BoundedChan-1.0.3.0
Building     base-compat-0.10.5
Completed    base-orphans-0.8
Starting     base16-bytestring-0.1.1.6
Completed    BoundedChan-1.0.3.0
Starting     basement-0.0.10
Completed    StateVar-1.1.1.1
Starting     cabal-doctest-1.0.6
Building     base16-bytestring-0.1.1.6
Building     basement-0.0.10
Building     cabal-doctest-1.0.6
Completed    base16-bytestring-0.1.1.6
Starting     data-default-class-0.1.2.0
Building     data-default-class-0.1.2.0
Completed    cabal-doctest-1.0.6
Starting     dlist-0.8.0.5
Building     dlist-0.8.0.5
Completed    data-default-class-0.1.2.0
Starting     fingertree-0.1.4.2
Building     fingertree-0.1.4.2
Completed    base-compat-0.10.5
Starting     half-0.3
Building     half-0.3
Completed    dlist-0.8.0.5
Starting     hashable-1.2.7.0
Building     hashable-1.2.7.0
Completed    half-0.3
Starting     lens-family-core-1.2.3
Building     lens-family-core-1.2.3
Completed    hashable-1.2.7.0
Starting     lens-family-th-0.5.0.2
Completed    fingertree-0.1.4.2
Starting     old-locale-1.0.0.7
Building     lens-family-th-0.5.0.2
Building     old-locale-1.0.0.7
Completed    lens-family-core-1.2.3
Starting     primitive-0.6.4.0
Completed    old-locale-1.0.0.7
Starting     random-1.1
Building     primitive-0.6.4.0
Building     random-1.1
Completed    lens-family-th-0.5.0.2
Starting     semigroups-0.18.5
Building     semigroups-0.18.5
Completed    semigroups-0.18.5
Starting     split-0.2.3.3
Building     split-0.2.3.3
Completed    random-1.1
Starting     tagged-0.8.6
Building     tagged-0.8.6
Completed    split-0.2.3.3
Starting     th-abstraction-0.2.11.0
Building     th-abstraction-0.2.11.0
Completed    tagged-0.8.6
Starting     transformers-compat-0.6.2
Building     transformers-compat-0.6.2
Completed    th-abstraction-0.2.11.0
Starting     unbounded-delays-0.1.1.0
Building     unbounded-delays-0.1.1.0
Completed    transformers-compat-0.6.2
Starting     unliftio-core-0.1.2.0
Completed    unbounded-delays-0.1.1.0
Starting     contravariant-1.5
Building     unliftio-core-0.1.2.0
Building     contravariant-1.5
Completed    primitive-0.6.4.0
Starting     data-default-instances-containers-0.0.1
Completed    unliftio-core-0.1.2.0
Starting     data-default-instances-dlist-0.0.1
Building     data-default-instances-containers-0.0.1
Building     data-default-instances-dlist-0.0.1
Completed    data-default-instances-containers-0.0.1
Starting     unordered-containers-0.2.10.0
Completed    data-default-instances-dlist-0.0.1
Starting     psqueues-0.2.7.1
Building     unordered-containers-0.2.10.0
Completed    contravariant-1.5
Starting     lens-family-1.2.3
Building     psqueues-0.2.7.1
Building     lens-family-1.2.3
Completed    lens-family-1.2.3
Starting     data-default-instances-old-locale-0.0.1
Building     data-default-instances-old-locale-0.0.1
Completed    data-default-instances-old-locale-0.0.1
Starting     distributive-0.6
Completed    psqueues-0.2.7.1
Starting     exceptions-0.10.0
Building     exceptions-0.10.0
Building     distributive-0.6
Completed    unordered-containers-0.2.10.0
Starting     concurrent-extra-0.7.0.12
Building     concurrent-extra-0.7.0.12
Completed    distributive-0.6
Starting     vector-0.12.0.2
Completed    exceptions-0.10.0
Starting     cborg-0.2.1.0
Completed    basement-0.0.10
Starting     lens-simple-0.1.0.9
Building     vector-0.12.0.2
Building     cborg-0.2.1.0
Building     lens-simple-0.1.0.9
Completed    concurrent-extra-0.7.0.12
Starting     data-default-0.7.1.1
Building     data-default-0.7.1.1
Completed    lens-simple-0.1.0.9
Starting     comonad-5.0.4
Completed    data-default-0.7.1.1
Starting     temporary-1.3
Building     temporary-1.3
Building     comonad-5.0.4
Completed    temporary-1.3
Starting     resourcet-1.2.2
Building     resourcet-1.2.2
Completed    comonad-5.0.4
Starting     memory-0.14.18
Completed    resourcet-1.2.2
Starting     bifunctors-5.5.3
Building     memory-0.14.18
Building     bifunctors-5.5.3
Completed    bifunctors-5.5.3
Starting     leveldb-haskell-0.6.5
Completed    memory-0.14.18
Starting     semigroupoids-5.3.2
Failed to install leveldb-haskell-0.6.5
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/leveldb-haskell-0.6.5-7Kp2qHIwwNyJRWy23zwONV.log ):
cabal: Entering directory '/tmp/cabal-tmp-15902/leveldb-haskell-0.6.5'
Configuring leveldb-haskell-0.6.5...
cabal: Missing dependency on a foreign library:
* Missing (or bad) C library: leveldb
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.If the
library file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.

cabal: Leaving directory '/tmp/cabal-tmp-15902/leveldb-haskell-0.6.5'
Starting     cryptonite-0.25
Building     cryptonite-0.25
Building     semigroupoids-5.3.2
Completed    vector-0.12.0.2
Completed    semigroupoids-5.3.2
Completed    cborg-0.2.1.0
Completed    cryptonite-0.25
cabal: Error: some packages failed to install:
dfinity-radix-tree-0.6.3-AP6Bqju8hVm3wg1aJyZX1D depends on
dfinity-radix-tree-0.6.3 which failed to install.
leveldb-haskell-0.6.5-7Kp2qHIwwNyJRWy23zwONV failed during the configure step.
The exception was:
ExitFailure 1