Build #1 for di-monad-1.0

[all reports]

Package di-monad-1.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2018-05-07 00:16:32.489289275 UTC
Compiler ghc-8.2.2
OS linux
Arch x86_64
Dependencies base-4.10.1.0, containers-0.5.10.2, di-core-1.0, exceptions-0.10.0, mtl-2.2.1, pipes-4.3.9, stm-2.4.4.1, transformers-0.5.2.0
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring semigroups-0.18.4...
Configuring transformers-compat-0.6.1.5...
Building semigroups-0.18.4...
Building transformers-compat-0.6.1.5...
Installed semigroups-0.18.4
Configuring void-0.7.2...
Building void-0.7.2...
Installed void-0.7.2
Installed transformers-compat-0.6.1.5
Configuring mmorph-1.1.2...
Configuring exceptions-0.10.0...
Building exceptions-0.10.0...
Building mmorph-1.1.2...
Installed mmorph-1.1.2
Installed exceptions-0.10.0
Downloading di-core-1.0...
Configuring pipes-4.3.9...
Configuring di-core-1.0...
Building di-core-1.0...
Building pipes-4.3.9...
Installed di-core-1.0
Installed pipes-4.3.9
Downloading di-monad-1.0...
Configuring di-monad-1.0...
Building di-monad-1.0...
Failed to install di-monad-1.0
Build log ( /home/builder/.cabal/logs/ghc-8.2.2/di-monad-1.0-IDkZUC94nht4Lq22MgK4o5.log ):
cabal: Entering directory '/tmp/cabal-tmp-12465/di-monad-1.0'
Configuring di-monad-1.0...
Preprocessing library for di-monad-1.0..
Building library for di-monad-1.0..
[1 of 1] Compiling Di.Monad         ( lib/Di/Monad.hs, dist/build/Di/Monad.o )

lib/Di/Monad.hs:65:32: error:
    Module
    ‘Control.Monad.Identity’
    does not export
    ‘IdentityT(IdentityT)’
   |
65 | import Control.Monad.Identity (IdentityT(IdentityT))
   |                                ^^^^^^^^^^^^^^^^^^^^

lib/Di/Monad.hs:76:1: error:
    Could not find module ‘Control.Monad.Trans.Accum’
    Perhaps you meant
      Control.Monad.Trans.Class (from transformers-0.5.2.0)
      Control.Monad.Trans.Cont (from transformers-0.5.2.0)
      Control.Monad.Trans.Error (from transformers-0.5.2.0)
    Use -v to see a list of the files searched for.
   |
76 | import Control.Monad.Trans.Accum (AccumT(AccumT))
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

lib/Di/Monad.hs:79:1: error:
    Could not find module ‘Control.Monad.Trans.Select’
    Perhaps you meant
      Control.Monad.Trans.Except (from transformers-0.5.2.0)
      Control.Monad.Trans.Class (from transformers-0.5.2.0)
      Control.Monad.Trans.Cont (from transformers-0.5.2.0)
    Use -v to see a list of the files searched for.
   |
79 | import Control.Monad.Trans.Select (SelectT(SelectT))
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-12465/di-monad-1.0'
cabal: Error: some packages failed to install:
di-monad-1.0-IDkZUC94nht4Lq22MgK4o5 failed during the building phase. The
exception was:
ExitFailure 1