direct-sqlite: Low-level binding to SQLite3. Includes UTF8 and BLOB support.

[ bsd3, database, library ] [ Propose Tags ]

This package is not very different from the other SQLite3 bindings out there, but it fixes a few deficiencies I was finding. It is not as complete as bindings-sqlite3, but is slightly higher-level, in that it supports marshalling of data values to and from the database. In particular, it supports strings encoded as UTF8, and BLOBs represented as ByteStrings. Version 1.1 adds the SQLite amalgamation file (version 3.7.5) to the project, so that there are no external dependencies.

Versions 1.0, 1.1, 2.0, 2.1, 2.2, 2.2.1, 2.3, 2.3.1, 2.3.2, 2.3.3, 2.3.3.1, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.3.11, 2.3.12, 2.3.13, 2.3.14, 2.3.15, 2.3.16, 2.3.17, 2.3.18, 2.3.19, 2.3.20, 2.3.21, 2.3.22, 2.3.23
Dependencies base (>=4.1 && <5), bytestring, utf8-string (>=0.3.5) [details]
License BSD-3-Clause
Copyright Copyright (c) 2009 Dan Knapp
Author Dan Knapp
Maintainer dankna@gmail.com
Category Database
Home page http://www.dankna.com/software/
Bug tracker http://www.dankna.com/issues/create/
Source repo head: darcs get http://dankna.com/software/darcs/direct-sqlite/
Uploaded by IreneKnapp at Thu Feb 10 19:07:26 UTC 2011
Distributions LTSHaskell:2.3.23, NixOS:2.3.23, Stackage:2.3.23, openSUSE:2.3.23
Downloads 15180 total (251 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]
Hackage Matrix CI

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees