Build #7 for encoding-0.6.5

[all reports]

Package encoding-0.6.5
Install ConfigureFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-28 06:31:22.357948 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies HaXml-1.25.3, array-0.5.1.1, base-4.9.0.0, binary-0.8.3.0, bytestring-0.10.8.1, containers-0.5.7.1, extensible-exceptions-0.1.1.4, ghc-8.0.1.20161018, ghc-prim-0.5.0.0, mtl-2.2.1, regex-compat-0.95.1
Flags splitbase newghc

Build log

[view raw]

Resolving dependencies...
Configuring extensible-exceptions-0.1.1.4...
Configuring mtl-2.2.1...
Building extensible-exceptions-0.1.1.4...
Building mtl-2.2.1...
Installed extensible-exceptions-0.1.1.4
Configuring random-1.1...
Building random-1.1...
Configuring text-1.2.2.1...
Installed mtl-2.2.1
Building text-1.2.2.1...
Configuring regex-base-0.93.2...
Installed random-1.1
Building regex-base-0.93.2...
Installed regex-base-0.93.2
Configuring regex-posix-0.95.2...
Building regex-posix-0.95.2...
Installed regex-posix-0.95.2
Configuring regex-compat-0.95.1...
Building regex-compat-0.95.1...
Installed regex-compat-0.95.1
Installed text-1.2.2.1
Configuring polyparse-1.12...
Building polyparse-1.12...
Installed polyparse-1.12
Configuring HaXml-1.25.3...
Building HaXml-1.25.3...
Installed HaXml-1.25.3
Configuring encoding-0.6.5...
Failed to install encoding-0.6.5
Build log ( /home/builder/.cabal/logs/encoding-0.6.5.log ):
cabal: Entering directory '/tmp/cabal-tmp-12689/encoding-0.6.5'
cabal: Leaving directory '/tmp/cabal-tmp-12689/encoding-0.6.5'
cabal: Error: some packages failed to install:
encoding-0.6.5 failed during the configure step. The exception was:
user error ('/opt/ghc/8.0.2/bin/ghc' exited with an error:

/tmp/cabal-tmp-12689/encoding-0.6.5/Data/Static.hs:38:26: error:
Illegal bang-pattern (use BangPatterns):
! v
)