exceptions: Extensible optionally-pure exceptions

[ bsd3, control, exceptions, library, monad ] [ Propose Tags ]

Extensible optionally-pure exceptions.


[Skip to Readme]
Versions [faq] 0.1, 0.1.0.1, 0.1.1, 0.2, 0.3, 0.3.1, 0.3.2, 0.3.3, 0.3.3.1, 0.4, 0.5, 0.6, 0.6.1, 0.7, 0.8, 0.8.0.1, 0.8.0.2, 0.8.1, 0.8.2.1, 0.8.3, 0.9.0, 0.10.0, 0.10.1, 0.10.2, 0.10.3 (info)
Change log CHANGELOG.markdown
Dependencies base (>=4.3 && <5), fail (==4.9.*), mtl (>=2.0 && <2.3), stm (>=2.2 && <3), template-haskell (>=2.2 && <2.16), transformers (>=0.2 && <0.6), transformers-compat (>=0.3 && <0.7) [details]
License BSD-3-Clause
Copyright Copyright (C) 2013-2015 Edward A. Kmett Copyright (C) 2012 Google Inc.
Author Edward A. Kmett
Maintainer Edward A. Kmett <ekmett@gmail.com>
Category Control, Exceptions, Monad
Home page http://github.com/ekmett/exceptions/
Bug tracker http://github.com/ekmett/exceptions/issues
Source repo head: git clone git://github.com/ekmett/exceptions.git
Uploaded by ryanglscott at Tue Aug 27 14:35:23 UTC 2019
Distributions Arch:0.10.3, Debian:0.10.0, Fedora:0.10.0, FreeBSD:0.8.0.2, LTSHaskell:0.10.2, NixOS:0.10.3, Stackage:0.10.2, openSUSE:0.10.3
Downloads 300364 total (1151 in the last 30 days)
Rating 2.0 (votes: 1) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2019-08-27 [all 1 reports]

Modules

[Index] [Quick Jump]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees


Readme for exceptions-0.10.3

[back to package description]

exceptions

Hackage Build Status

This package provides (optionally pure) extensible exceptions that are compatible with the monad transformer library.

Contact Information

Contributions and bug reports are welcome!

Please feel free to contact me through github or on the #haskell IRC channel on irc.freenode.net.

-Edward Kmett