The extensible-effects package

[maintain]
Warnings:

This package introduces datatypes for typeclass-constrained effects, as an alternative to monad-transformer based (datatype-constrained) approach of multi-layered effects. For more information, see the original paper at http://okmij.org/ftp/Haskell/extensible/exteff.pdf. Any help is appreciated!

Properties

Versions1.0, 1.1.0, 1.2.0, 1.2.1, 1.4.1, 1.5.0, 1.6.0, 1.7.1, 1.7.1.0, 1.7.1.0, 1.7.1.1, 1.7.1.2, 1.7.2.1, 1.8.0.0, 1.8.1.0, 1.9.0.0, 1.9.0.1, 1.9.1.0, 1.9.2.2, 1.10.0.1, 1.11.0.0, 1.11.0.1, 1.11.0.2, 1.11.0.3, 1.11.0.4
Dependenciesbase (>=4.6 && <5), transformers (>=0.3 && <0.5), transformers-base (==0.4.*) [details]
LicenseMIT
AuthorOleg Kiselyov, Amr Sabry, Cameron Swords, Ben Foppa
Maintainerbenjamin.foppa@gmail.com
StabilityExperimental
CategoryControl, Effect
Home pagehttps://github.com/RobotGymnast/extensible-effects
Source repositoryhead: git clone https://github.com/RobotGymnast/extensible-effects.git
UploadedTue Nov 18 08:47:56 UTC 2014 by shergill

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees