Build #3 for fbmessenger-api-0.1.2.1

[all reports]

Package fbmessenger-api-0.1.2.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-11-17 03:50:55.149558 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies aeson-1.0.2.1, base-4.9.0.0, bytestring-0.10.8.1, case-insensitive-1.2.0.7, http-client-0.5.4, http-media-0.6.4, http-types-0.9.1, mime-types-0.1.0.7, servant-0.9.1.1, servant-client-0.9.1.1, string-conversions-0.4, text-1.2.2.1, transformers-0.5.2.0, unordered-containers-0.2.7.1, aeson-1.0.2.1, base-4.9.0.0, bytestring-0.10.8.1, http-client-0.5.4, http-client-tls-0.3.3, monad-logger-0.3.20.1, servant-0.9.1.1, servant-server-0.9.1.1, stm-2.4.4.1, text-1.2.2.1, transformers-0.5.2.0, wai-3.2.1.1, wai-logger-2.3.0, warp-3.2.9
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring ansi-terminal-0.6.2.3...
Configuring appar-0.1.4...
Building appar-0.1.4...
Building ansi-terminal-0.6.2.3...
Installed appar-0.1.4
Configuring auto-update-0.1.4...
Building auto-update-0.1.4...
Configuring base-compat-0.9.1...
Installed ansi-terminal-0.6.2.3
Building base-compat-0.9.1...
Configuring byteable-0.1.1...
Installed auto-update-0.1.4
Building byteable-0.1.1...
Configuring base64-bytestring-1.0.0.1...
Installed byteable-0.1.1
Building base64-bytestring-1.0.0.1...
Configuring byteorder-1.0.4...
Installed base-compat-0.9.1
Building byteorder-1.0.4...
Configuring bytestring-builder-0.10.8.1.0...
Installed byteorder-1.0.4
Configuring cereal-0.5.4.0...
Installed base64-bytestring-1.0.0.1
Building bytestring-builder-0.10.8.1.0...
Building cereal-0.5.4.0...
Configuring data-default-class-0.1.2.0...
Installed bytestring-builder-0.10.8.1.0
Building data-default-class-0.1.2.0...
Configuring dlist-0.8.0.2...
Installed data-default-class-0.1.2.0
Building dlist-0.8.0.2...
Configuring easy-file-0.2.1...
Installed cereal-0.5.4.0
Configuring file-embed-0.0.10...
Installed dlist-0.8.0.2
Building easy-file-0.2.1...
Building file-embed-0.0.10...
Configuring hourglass-0.2.10...
Installed easy-file-0.2.1
Building hourglass-0.2.10...
Configuring memory-0.13...
Installed file-embed-0.0.10
Building memory-0.13...
Configuring monad-loops-0.4.3...
Installed memory-0.13
Configuring mtl-2.2.1...
Installed hourglass-0.2.10
Building monad-loops-0.4.3...
Building mtl-2.2.1...
Configuring network-2.6.3.1...
Installed monad-loops-0.4.3
Configuring old-locale-1.0.0.7...
Installed mtl-2.2.1
Building network-2.6.3.1...
Building old-locale-1.0.0.7...
Configuring primitive-0.6.1.0...
Installed old-locale-1.0.0.7
Building primitive-0.6.1.0...
Configuring random-1.1...
Installed primitive-0.6.1.0
Building random-1.1...
Configuring safe-0.3.10...
Installed network-2.6.3.1
Building safe-0.3.10...
Configuring semigroups-0.18.2...
Installed random-1.1
Configuring split-0.2.3.1...
Installed safe-0.3.10
Building semigroups-0.18.2...
Building split-0.2.3.1...
Configuring stm-2.4.4.1...
Installed semigroups-0.18.2
Configuring stringsearch-0.3.6.6...
Installed split-0.2.3.1
Building stm-2.4.4.1...
Building stringsearch-0.3.6.6...
Configuring text-1.2.2.1...
Installed stm-2.4.4.1
Building text-1.2.2.1...
Configuring time-locale-compat-0.1.1.3...
Installed stringsearch-0.3.6.6
Building time-locale-compat-0.1.1.3...
Configuring transformers-compat-0.5.1.4...
Installed time-locale-compat-0.1.1.3
Building transformers-compat-0.5.1.4...
Configuring unix-compat-0.4.2.0...
Installed transformers-compat-0.5.1.4
Building unix-compat-0.4.2.0...
Configuring utf8-string-1.0.1.1...
Installed unix-compat-0.4.2.0
Building utf8-string-1.0.1.1...
Configuring word8-0.1.2...
Installed utf8-string-1.0.1.1
Building word8-0.1.2...
Configuring zlib-0.6.1.2...
Installed word8-0.1.2
Installed text-1.2.2.1
Configuring ansi-wl-pprint-0.6.7.3...
Building zlib-0.6.1.2...
Building ansi-wl-pprint-0.6.7.3...
Installed ansi-wl-pprint-0.6.7.3
Configuring asn1-types-0.3.2...
Building asn1-types-0.3.2...
Configuring cryptonite-0.20...
Installed zlib-0.6.1.2
Building cryptonite-0.20...
Configuring pem-0.2.2...
Installed asn1-types-0.3.2
Building pem-0.2.2...
Configuring old-time-1.1.0.3...
Installed pem-0.2.2
Building old-time-1.1.0.3...
Configuring vector-0.11.0.0...
Installed old-time-1.1.0.3
Building vector-0.11.0.0...
Configuring iproute-1.7.1...
Installed cryptonite-0.20
Building iproute-1.7.1...
Configuring socks-0.5.5...
Installed vector-0.11.0.0
Building socks-0.5.5...
Configuring simple-sendfile-0.2.25...
Installed iproute-1.7.1
Configuring async-2.1.0...
Installed socks-0.5.5
Building simple-sendfile-0.2.25...
Building async-2.1.0...
Configuring stm-chans-3.0.0.4...
Installed simple-sendfile-0.2.25
Configuring mmorph-1.0.6...
Installed async-2.1.0
Building mmorph-1.0.6...
Configuring exceptions-0.8.3...
Installed mmorph-1.0.6
Building exceptions-0.8.3...
Building stm-chans-3.0.0.4...
Configuring transformers-base-0.4.4...
Installed stm-chans-3.0.0.4
Building transformers-base-0.4.4...
Configuring tagged-0.8.5...
Installed exceptions-0.8.3
Building tagged-0.8.5...
Installed transformers-base-0.4.4
Configuring hashable-1.2.4.0...
Building hashable-1.2.4.0...
Configuring blaze-builder-0.4.0.2...
Installed tagged-0.8.5
Building blaze-builder-0.4.0.2...
Configuring mime-types-0.1.0.7...
Installed hashable-1.2.4.0
Building mime-types-0.1.0.7...
Configuring string-conversions-0.4...
Installed blaze-builder-0.4.0.2
Building string-conversions-0.4...
Configuring parsec-3.1.11...
Installed string-conversions-0.4
Building parsec-3.1.11...
Configuring system-filepath-0.4.13.4...
Installed mime-types-0.1.0.7
Building system-filepath-0.4.13.4...
Installed parsec-3.1.11
Configuring optparse-applicative-0.13.0.0...
Building optparse-applicative-0.13.0.0...
Installed system-filepath-0.4.13.4
Configuring asn1-encoding-0.9.4...
Building asn1-encoding-0.9.4...
Configuring monad-control-1.0.1.0...
Installed asn1-encoding-0.9.4
Configuring unix-time-0.3.7...
Installed optparse-applicative-0.13.0.0
Building monad-control-1.0.1.0...
Building unix-time-0.3.7...
Configuring case-insensitive-1.2.0.7...
Installed monad-control-1.0.1.0
Building case-insensitive-1.2.0.7...
Configuring scientific-0.3.4.9...
Installed unix-time-0.3.7
Building scientific-0.3.4.9...
Configuring psqueues-0.2.2.2...
Installed case-insensitive-1.2.0.7
Building psqueues-0.2.2.2...
Configuring uuid-types-1.0.3...
Installed scientific-0.3.4.9
Building uuid-types-1.0.3...
Configuring unordered-containers-0.2.7.1...
Installed psqueues-0.2.2.2
Building unordered-containers-0.2.7.1...
Configuring void-0.7.1...
Installed uuid-types-1.0.3
Building void-0.7.1...
Configuring blaze-markup-0.7.1.0...
Installed void-0.7.1
Building blaze-markup-0.7.1.0...
Configuring cookie-0.4.2.1...
Installed blaze-markup-0.7.1.0
Building cookie-0.4.2.1...
Configuring streaming-commons-0.1.16...
Installed unordered-containers-0.2.7.1
Building streaming-commons-0.1.16...
Configuring network-uri-2.6.1.0...
Installed cookie-0.4.2.1
Building network-uri-2.6.1.0...
Installed network-uri-2.6.1.0
Configuring asn1-parse-0.9.4...
Building asn1-parse-0.9.4...
Configuring lifted-base-0.2.3.8...
Installed streaming-commons-0.1.16
Configuring fast-logger-2.4.7...
Installed asn1-parse-0.9.4
Building lifted-base-0.2.3.8...
Building fast-logger-2.4.7...
Configuring http-media-0.6.4...
Installed lifted-base-0.2.3.8
Configuring http-types-0.9.1...
Installed fast-logger-2.4.7
Building http-media-0.6.4...
Building http-types-0.9.1...
Configuring attoparsec-0.13.1.0...
Installed http-media-0.6.4
Building attoparsec-0.13.1.0...
Configuring http2-1.6.2...
Installed http-types-0.9.1
Building http2-1.6.2...
Configuring vault-0.3.0.6...
Installed attoparsec-0.13.1.0
Building vault-0.3.0.6...
Configuring blaze-html-0.8.1.2...
Installed vault-0.3.0.6
Building blaze-html-0.8.1.2...
Installed http2-1.6.2
Configuring x509-1.6.4...
Building x509-1.6.4...
Configuring resourcet-1.1.8.1...
Installed x509-1.6.4
Building resourcet-1.1.8.1...
Configuring http-client-0.5.4...
Installed resourcet-1.1.8.1
Building http-client-0.5.4...
Configuring aeson-1.0.2.1...
Installed blaze-html-0.8.1.2
Building aeson-1.0.2.1...
Configuring uri-bytestring-0.2.2.0...
Installed http-client-0.5.4
Building uri-bytestring-0.2.2.0...
Configuring http-date-0.0.6.1...
Installed uri-bytestring-0.2.2.0
Building http-date-0.0.6.1...
Configuring wai-3.2.1.1...
Installed http-date-0.0.6.1
Building wai-3.2.1.1...
Installed wai-3.2.1.1
Configuring x509-store-1.6.2...
Building x509-store-1.6.2...
Installed x509-store-1.6.2
Configuring http-api-data-0.3.3...
Configuring conduit-1.2.8...
Installed aeson-1.0.2.1
Building conduit-1.2.8...
Building http-api-data-0.3.3...
Configuring wai-logger-2.3.0...
Installed http-api-data-0.3.3
Building wai-logger-2.3.0...
Installed conduit-1.2.8
Configuring warp-3.2.9...
Building warp-3.2.9...
Installed wai-logger-2.3.0
Configuring x509-system-1.6.4...
Building x509-system-1.6.4...
Configuring x509-validation-1.6.5...
Installed x509-system-1.6.4
Building x509-validation-1.6.5...
Installed x509-validation-1.6.5
Configuring servant-0.9.1.1...
Building servant-0.9.1.1...
Configuring conduit-extra-1.1.15...
Installed warp-3.2.9
Building conduit-extra-1.1.15...
Configuring wai-extra-3.0.19...
Installed servant-0.9.1.1
Building wai-extra-3.0.19...
Configuring tls-1.3.8...
Installed conduit-extra-1.1.15
Building tls-1.3.8...
Configuring monad-logger-0.3.20.1...
Installed wai-extra-3.0.19
Building monad-logger-0.3.20.1...
Installed monad-logger-0.3.20.1
Configuring wai-app-static-3.1.6.1...
Building wai-app-static-3.1.6.1...
Installed tls-1.3.8
Configuring connection-0.2.6...
Building connection-0.2.6...
Installed connection-0.2.6
Configuring http-client-tls-0.3.3...
Building http-client-tls-0.3.3...
Installed wai-app-static-3.1.6.1
Configuring servant-server-0.9.1.1...
Building servant-server-0.9.1.1...
Installed http-client-tls-0.3.3
Configuring servant-client-0.9.1.1...
Building servant-client-0.9.1.1...
Installed servant-client-0.9.1.1
Installed servant-server-0.9.1.1
Configuring fbmessenger-api-0.1.2.1...
Building fbmessenger-api-0.1.2.1...
Failed to install fbmessenger-api-0.1.2.1
Build log ( /home/builder/.cabal/logs/fbmessenger-api-0.1.2.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-22074/fbmessenger-api-0.1.2.1'
Configuring fbmessenger-api-0.1.2.1...
Building fbmessenger-api-0.1.2.1...
Preprocessing library fbmessenger-api-0.1.2.1...

on the commandline: warning:
    unrecognised warning flag: -fwarn-pointless-pragmas
[1 of 7] Compiling Web.FBMessenger.API.Bot.JsonExt ( src/Web/FBMessenger/API/Bot/JsonExt.hs, dist/build/Web/FBMessenger/API/Bot/JsonExt.o )
[2 of 7] Compiling Web.FBMessenger.API.Bot.Responses ( src/Web/FBMessenger/API/Bot/Responses.hs, dist/build/Web/FBMessenger/API/Bot/Responses.o )
[3 of 7] Compiling Web.FBMessenger.API.Bot.WebhookAPI ( src/Web/FBMessenger/API/Bot/WebhookAPI.hs, dist/build/Web/FBMessenger/API/Bot/WebhookAPI.o )
[4 of 7] Compiling Servant.Client.MultipartFormData ( src/Servant/Client/MultipartFormData.hs, dist/build/Servant/Client/MultipartFormData.o )

src/Servant/Client/MultipartFormData.hs:70:34: error:
    Not in scope: ‘checkStatus’
cabal: Leaving directory '/tmp/cabal-tmp-22074/fbmessenger-api-0.1.2.1'
cabal: Error: some packages failed to install:
fbmessenger-api-0.1.2.1 failed during the building phase. The exception was:
ExitFailure 1