Build #3 for festung-0.9.1.2

[all reports]

Package festung-0.9.1.2
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2018-06-28 21:54:01.089096361 UTC
Compiler ghc-8.4.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: festung-0.9.1.2 (user goal)
[__1] trying: transformers-0.5.5.0/installed-0.5... (dependency of festung)
[__2] next goal: either (dependency of festung)
[__2] rejecting: either-5 (conflict: festung => either<5)
[__2] trying: either-4.5
[__3] next goal: free (dependency of either)
[__3] rejecting: free-5.0.2, free-5.0.1, free-5 (conflict: either => free>=4.9
&& <5)
[__3] rejecting: free-4.12.4, free-4.12.3 (conflict: transformers =>
base==4.11.1.0/installed-4.1..., free => base==4.* && <4.11)
[__3] trying: free-4.12.2
[__4] next goal: comonad (dependency of free)
[__4] rejecting: comonad-5.0.3, comonad-5.0.2, comonad-5.0.1, comonad-5
(conflict: free => comonad==4.*)
[__4] rejecting: comonad-4.3 (conflict: transformers =>
base==4.11.1.0/installed-4.1..., comonad => base>=0 && <0)
[__4] rejecting: comonad-4.2.7.2, comonad-4.2.7.1 (conflict:
transformers==0.5.5.0/installed-0.5..., comonad => transformers>=0.2 && <0.5)
[__4] rejecting: comonad-4.2.7 (conflict: transformers =>
base==4.11.1.0/installed-4.1..., comonad => base<0)
[__4] rejecting: comonad-4.2.6, comonad-4.2.5, comonad-4.2.4, comonad-4.2.3,
comonad-4.2.2, comonad-4.2.1, comonad-4.2 (conflict:
transformers==0.5.5.0/installed-0.5..., comonad => transformers>=0.2 && <0.5)
[__4] rejecting: comonad-4.0.1, comonad-4.0 (conflict:
transformers==0.5.5.0/installed-0.5..., comonad => transformers>=0.2 && <0.4)
[__4] rejecting: comonad-3.1, comonad-3.0.3, comonad-3.0.2, comonad-3.0.1.1,
comonad-3.0.0.2, comonad-3.0.0.1, comonad-3.0, comonad-1.1.1.6,
comonad-1.1.1.5, comonad-1.1.1.4, comonad-1.1.1.3, comonad-1.1.1.2,
comonad-1.1.1.1, comonad-1.1.1, comonad-1.1.0.2, comonad-1.1.0.1,
comonad-1.1.0, comonad-1.0.3, comonad-1.0.2, comonad-1.0.1, comonad-1.0,
comonad-0.9.0.1, comonad-0.9.0, comonad-0.7.0, comonad-0.6.2.1, comonad-0.6.2,
comonad-0.6.1.2, comonad-0.6.1.1, comonad-0.6.1, comonad-0.6.0, comonad-0.5.0,
comonad-0.4.0, comonad-0.3.0, comonad-0.1.1, comonad-0.1.0 (conflict: free =>
comonad==4.*)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: free, transformers, either, comonad,
base, festung