Build #8 for follower-0.0.1

[all reports]

Package follower-0.0.1
Install DependencyFailed hs-twitter-0.2.8
Docs NotTried
Tests NotTried
Time submitted 2016-12-28 14:52:26.405468 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies ansi-wl-pprint-0.6.7.3, base-4.9.0.0, cmdargs-0.10.14, directory-1.2.6.2, filepath-1.4.1.0, hs-twitter-0.2.8, old-locale-1.0.0.7, strict-0.3.2, time-1.6.0.1
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring ansi-terminal-0.6.2.3...
Configuring cmdargs-0.10.14...
Building cmdargs-0.10.14...
Building ansi-terminal-0.6.2.3...
Installed ansi-terminal-0.6.2.3
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Configuring old-locale-1.0.0.7...
Installed mtl-2.2.1
Building old-locale-1.0.0.7...
Configuring random-1.1...
Installed old-locale-1.0.0.7
Building random-1.1...
Configuring network-2.6.3.1...
Installed random-1.1
Building network-2.6.3.1...
Configuring strict-0.3.2...
Installed cmdargs-0.10.14
Building strict-0.3.2...
Configuring utf8-string-1.0.1.1...
Installed strict-0.3.2
Building utf8-string-1.0.1.1...
Configuring syb-0.6...
Installed network-2.6.3.1
Building syb-0.6...
Configuring ansi-wl-pprint-0.6.7.3...
Installed utf8-string-1.0.1.1
Building ansi-wl-pprint-0.6.7.3...
Configuring text-1.2.2.1...
Installed ansi-wl-pprint-0.6.7.3
Installed syb-0.6
Configuring old-time-1.1.0.3...
Building text-1.2.2.1...
Building old-time-1.1.0.3...
Installed old-time-1.1.0.3
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Configuring mime-0.4.0.2...
Building parsec-3.1.11...
Building mime-0.4.0.2...
Installed mime-0.4.0.2
Installed parsec-3.1.11
Configuring network-uri-2.6.1.0...
Configuring json-0.9.1...
Building network-uri-2.6.1.0...
Building json-0.9.1...
Installed network-uri-2.6.1.0
Configuring HTTP-4000.3.3...
Building HTTP-4000.3.3...
Installed json-0.9.1
Installed HTTP-4000.3.3
Configuring hs-twitter-0.2.8...
Building hs-twitter-0.2.8...
Failed to install hs-twitter-0.2.8
Build log ( /home/builder/.cabal/logs/hs-twitter-0.2.8.log ):
cabal: Entering directory '/tmp/cabal-tmp-29319/hs-twitter-0.2.8'
Configuring hs-twitter-0.2.8...
Building hs-twitter-0.2.8...
Preprocessing library hs-twitter-0.2.8...
[1 of 9] Compiling Web.Twitter.Types ( Web/Twitter/Types.hs, dist/build/Web/Twitter/Types.o )
[2 of 9] Compiling Web.Twitter.Types.Import ( Web/Twitter/Types/Import.hs, dist/build/Web/Twitter/Types/Import.o )

Web/Twitter/Types/Import.hs:16:10: error:
    • No instance for (Applicative JM)
        arising from the superclasses of an instance declaration
    • In the instance declaration for ‘Monad JM’
cabal: Leaving directory '/tmp/cabal-tmp-29319/hs-twitter-0.2.8'
cabal: Error: some packages failed to install:
follower-0.0.1 depends on hs-twitter-0.2.8 which failed to install.
hs-twitter-0.2.8 failed during the building phase. The exception was:
ExitFailure 1