Build #3 for funcons-lambda-cbv-mp-0.1.0.2

[all reports]

Package funcons-lambda-cbv-mp-0.1.0.2
Install DependencyFailed funcons-lambda-cbv-mp-0.1.0.2
Docs NotTried
Tests NotTried
Time submitted 2018-07-08 10:34:46.180964222 UTC
Compiler ghc-8.4.3
OS linux
Arch x86_64
Dependencies base-4.11.1.0, containers-0.5.11.0, funcons-tools-0.2.0.5, gll-0.4.0.5, text-1.2.3.0
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring bv-0.5...
Configuring base-orphans-0.8...
Building bv-0.5...
Building base-orphans-0.8...
Installed bv-0.5
Configuring multiset-0.3.4...
Installed base-orphans-0.8
Configuring primitive-0.6.4.0...
Building multiset-0.3.4...
Building primitive-0.6.4.0...
Installed multiset-0.3.4
Configuring random-1.1...
Building random-1.1...
Installed random-1.1
Configuring regex-applicative-0.3.3...
Building regex-applicative-0.3.3...
Installed regex-applicative-0.3.3
Configuring split-0.2.3.3...
Building split-0.2.3.3...
Installed primitive-0.6.4.0
Configuring TypeCompose-0.9.12...
Installed split-0.2.3.3
Configuring random-strings-0.1.1.0...
Building TypeCompose-0.9.12...
Building random-strings-0.1.1.0...
Failed to install TypeCompose-0.9.12
Build log ( /home/builder/.cabal/logs/ghc-8.4.3/TypeCompose-0.9.12-4FepCXFvbF94E2D2EggnNC.log ):
cabal: Entering directory '/tmp/cabal-tmp-13775/TypeCompose-0.9.12'
Configuring TypeCompose-0.9.12...
Preprocessing library for TypeCompose-0.9.12..
Building library for TypeCompose-0.9.12..

src/Data/Title.hs:1:33: warning:
    -XOverlappingInstances is deprecated: instead use per-instance pragmas OVERLAPPING/OVERLAPPABLE/OVERLAPS
  |
1 | {-# LANGUAGE FlexibleInstances, OverlappingInstances, TypeOperators, TypeSynonymInstances #-}
  |                                 ^^^^^^^^^^^^^^^^^^^^
[ 1 of 10] Compiling Control.Instances ( src/Control/Instances.hs, dist/build/Control/Instances.o )
[ 2 of 10] Compiling Data.Bijection   ( src/Data/Bijection.hs, dist/build/Data/Bijection.o )
[ 3 of 10] Compiling Control.Compose  ( src/Control/Compose.hs, dist/build/Control/Compose.o )

src/Control/Compose.hs:596:10: error:
    • Could not deduce (Semigroup (Flip j o a))
        arising from the superclasses of an instance declaration
      from the context: (Applicative (j a), Monoid o)
        bound by the instance declaration
        at src/Control/Compose.hs:596:10-61
    • In the instance declaration for ‘Monoid (Flip j o a)’
    |
596 | instance (Applicative (j a), Monoid o) => Monoid (Flip j o a) where
    |          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

src/Control/Compose.hs:645:10: error:
    • Could not deduce (Semigroup (App f m))
        arising from the superclasses of an instance declaration
      from the context: (Applicative f, Monoid m)
        bound by the instance declaration
        at src/Control/Compose.hs:645:10-54
    • In the instance declaration for ‘Monoid (App f m)’
    |
645 | instance (Applicative f, Monoid m) => Monoid (App f m) where
    |          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

src/Control/Compose.hs:851:1: error:
    • Could not deduce (Semigroup (Arrw j f g a))
        arising from the superclasses of an instance declaration
      from the context: Monoid (j (f a) (g a))
        bound by the instance declaration
        at src/Control/Compose.hs:851:1-63
    • In the instance declaration for ‘Monoid (Arrw j f g a)’
    |
851 | deriving instance Monoid (f a `j` g a) => Monoid (Arrw j f g a)
    | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-13775/TypeCompose-0.9.12'
Configuring vector-0.12.0.1...
Building vector-0.12.0.1...
Installed random-strings-0.1.1.0
Installed vector-0.12.0.1
cabal: Error: some packages failed to install:
TypeCompose-0.9.12-4FepCXFvbF94E2D2EggnNC failed during the building phase.
The exception was:
ExitFailure 1
funcons-lambda-cbv-mp-0.1.0.2-EchkTjRhyj8Iy3NQY3l20S depends on
funcons-lambda-cbv-mp-0.1.0.2 which failed to install.
funcons-tools-0.2.0.5-1arshdAwsbw7JhtSgabFmb depends on funcons-tools-0.2.0.5
which failed to install.
gll-0.4.0.5-JJUrfPg6eYkDGW20RyApYs depends on gll-0.4.0.5 which failed to
install.