Build #3 for gen-imports-0.1.0.1

[all reports]

Package gen-imports-0.1.0.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2018-01-17 14:03:42.065845364 UTC
Compiler ghc-8.2.2
OS linux
Arch x86_64
Dependencies Cabal-2.0.1.0, base-4.10.1.0, bytestring-0.10.8.2, containers-0.5.10.2, filepath-1.4.1.2, hackage-db-1.22, pretty-1.1.3.3
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring tar-0.5.0.3...
Configuring utf8-string-1.0.1.1...
Building tar-0.5.0.3...
Building utf8-string-1.0.1.1...
Installed utf8-string-1.0.1.1
Installed tar-0.5.0.3
Configuring hackage-db-1.22...
Building hackage-db-1.22...
Installed hackage-db-1.22
Configuring gen-imports-0.1.0.1...
Building gen-imports-0.1.0.1...
Failed to install gen-imports-0.1.0.1
Build log ( /home/builder/.cabal/logs/ghc-8.2.2/gen-imports-0.1.0.1-v22gNrhPIr9CdAuBgh7r2.log ):
cabal: Entering directory '/tmp/cabal-tmp-28991/gen-imports-0.1.0.1'
Configuring gen-imports-0.1.0.1...
Preprocessing library for gen-imports-0.1.0.1..
Building library for gen-imports-0.1.0.1..
[1 of 1] Compiling Distribution.Hackage.Imports.Generate ( src/Distribution/Hackage/Imports/Generate.hs, dist/build/Distribution/Hackage/Imports/Generate.o )

src/Distribution/Hackage/Imports/Generate.hs:15:30: error:
    Module
    ‘Distribution.Version’
    does not export
    ‘Version(versionBranch)’
   |
15 | import Distribution.Version (Version(versionBranch))
   |                              ^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-28991/gen-imports-0.1.0.1'
cabal: Error: some packages failed to install:
gen-imports-0.1.0.1-v22gNrhPIr9CdAuBgh7r2 failed during the building phase.
The exception was:
ExitFailure 1