Build #1 for gi-gtk-hs-0.3.8.0

[all reports]

Package gi-gtk-hs-0.3.8.0
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2019-08-04 11:28:32.916268271 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: gi-gtk-hs-0.3.8.0 (user goal)
[__1] trying: haskell-gi-base-0.23.0 (dependency of gi-gtk-hs)
[__2] next goal: gi-gtk (dependency of gi-gtk-hs)
[__2] rejecting: gi-gtk-4.0.1 (conflict: gi-gtk-hs => gi-gtk>=3.0.26 && <3.1)
[__2] rejecting: gi-gtk-3.0.32 (conflict: pkg-config package gtk+-3.0-any, not
found in the pkg-config database)
[__2] rejecting: gi-gtk-3.0.31, gi-gtk-3.0.30 (conflict:
haskell-gi-base==0.23.0, gi-gtk => haskell-gi-base>=0.22.0 && <0.23)
[__2] rejecting: gi-gtk-3.0.29, gi-gtk-3.0.28 (conflict:
haskell-gi-base==0.23.0, gi-gtk => haskell-gi-base>=0.21.0 && <0.23)
[__2] rejecting: gi-gtk-3.0.27, gi-gtk-3.0.26 (conflict:
haskell-gi-base==0.23.0, gi-gtk => haskell-gi-base==0.21.*)
[__2] rejecting: gi-gtk-3.0.25, gi-gtk-3.0.24, gi-gtk-3.0.23, gi-gtk-3.0.22,
gi-gtk-3.0.21, gi-gtk-3.0.20, gi-gtk-3.0.19, gi-gtk-3.0.18, gi-gtk-3.0.17,
gi-gtk-3.0.16, gi-gtk-3.0.15, gi-gtk-3.0.14, gi-gtk-3.0.13, gi-gtk-3.0.12,
gi-gtk-3.0.11, gi-gtk-3.0.10, gi-gtk-3.0.9, gi-gtk-3.0.8, gi-gtk-3.0.7,
gi-gtk-3.0.6, gi-gtk-3.0.5, gi-gtk-3.0.4, gi-gtk-3.0.3, gi-gtk-3.0.2,
gi-gtk-3.0.1, gi-gtk-0.3.18.15, gi-gtk-0.3.18.14, gi-gtk-0.3.18.13,
gi-gtk-0.3.18.12, gi-gtk-0.3.16.12, gi-gtk-0.3.18.10, gi-gtk-0.3.16.11,
gi-gtk-0.3.16.10, gi-gtk-0.3.16.9, gi-gtk-0.3.16.8 (conflict: gi-gtk-hs =>
gi-gtk>=3.0.26 && <3.1)
[__2] fail (backjumping, conflict set: gi-gtk, gi-gtk-hs, haskell-gi-base)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: gi-gtk-hs, gi-gtk, haskell-gi-base