Build #7 for gloss-examples-1.0.0.0

[all reports]

Package gloss-examples-1.0.0.0
Install DependencyFailed gloss-1.0.0.0
Docs NotTried
Tests NotTried
Time submitted 2016-12-30 14:11:06.721149 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, gloss-1.0.0.0, base-4.9.0.0, gloss-1.0.0.0, base-4.9.0.0, gloss-1.0.0.0, random-1.1, base-4.9.0.0, gloss-1.0.0.0, base-4.9.0.0, gloss-1.0.0.0, base-4.9.0.0, gloss-1.0.0.0, random-1.1, base-4.9.0.0, containers-0.5.7.1, ghc-prim-0.5.0.0, gloss-1.0.0.0, base-4.9.0.0, gloss-1.0.0.0, base-4.9.0.0, gloss-1.0.0.0
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring ObjectName-1.1.0.1...
Configuring fixed-0.2.1.1...
Building ObjectName-1.1.0.1...
Building fixed-0.2.1.1...
Installed ObjectName-1.1.0.1
Configuring half-0.2.2.3...
Configuring random-1.1...
Installed fixed-0.2.1.1
Building half-0.2.2.3...
Building random-1.1...
Configuring stm-2.4.4.1...
Installed half-0.2.2.3
Building stm-2.4.4.1...
Configuring text-1.2.2.1...
Installed random-1.1
Building text-1.2.2.1...
Installed stm-2.4.4.1
Configuring StateVar-1.1.0.4...
Building StateVar-1.1.0.4...
Installed StateVar-1.1.0.4
Installed text-1.2.2.1
Configuring OpenGLRaw-3.2.4.0...
Building OpenGLRaw-3.2.4.0...
Installed OpenGLRaw-3.2.4.0
Configuring GLURaw-2.0.0.3...
Building GLURaw-2.0.0.3...
Installed GLURaw-2.0.0.3
Configuring OpenGL-3.0.1.0...
Building OpenGL-3.0.1.0...
Installed OpenGL-3.0.1.0
Configuring GLUT-2.7.0.10...
Building GLUT-2.7.0.10...
Installed GLUT-2.7.0.10
Configuring gloss-1.0.0.0...
Building gloss-1.0.0.0...
Failed to install gloss-1.0.0.0
Build log ( /home/builder/.cabal/logs/gloss-1.0.0.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-32000/gloss-1.0.0.0'
Configuring gloss-1.0.0.0...
Building gloss-1.0.0.0...
Preprocessing library gloss-1.0.0.0...

Graphics/Gloss/Internals/Render/Circle.hs:1:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead
[ 1 of 31] Compiling Graphics.Gloss.ViewPort ( Graphics/Gloss/ViewPort.hs, dist/build/Graphics/Gloss/ViewPort.o )

Graphics/Gloss/ViewPort.hs:5:1: warning: [-Wtabs]
    Tab character found here, and in 29 further locations.
    Please use spaces instead.
[ 2 of 31] Compiling Graphics.Gloss.Internals.Render.ViewPort ( Graphics/Gloss/Internals/Render/ViewPort.hs, dist/build/Graphics/Gloss/Internals/Render/ViewPort.o )

Graphics/Gloss/Internals/Render/ViewPort.hs:6:1: warning: [-Wtabs]
    Tab character found here, and in 103 further locations.
    Please use spaces instead.
[ 3 of 31] Compiling Graphics.Gloss.Internals.Render.Options ( Graphics/Gloss/Internals/Render/Options.hs, dist/build/Graphics/Gloss/Internals/Render/Options.o )

Graphics/Gloss/Internals/Render/Options.hs:5:1: warning: [-Wtabs]
    Tab character found here, and in 28 further locations.
    Please use spaces instead.
[ 4 of 31] Compiling Graphics.Gloss.Internals.Render.Common ( Graphics/Gloss/Internals/Render/Common.hs, dist/build/Graphics/Gloss/Internals/Render/Common.o )

Graphics/Gloss/Internals/Render/Common.hs:4:46: warning: [-Wtabs]
    Tab character found here.
    Please use spaces instead.
[ 5 of 31] Compiling Graphics.Gloss.Internals.Render.Circle ( Graphics/Gloss/Internals/Render/Circle.hs, dist/build/Graphics/Gloss/Internals/Render/Circle.o )

Graphics/Gloss/Internals/Render/Circle.hs:38:9: error:
    Illegal bang-pattern (use BangPatterns):
    ! (F# tStep)
cabal: Leaving directory '/tmp/cabal-tmp-32000/gloss-1.0.0.0'
cabal: Error: some packages failed to install:
gloss-1.0.0.0 failed during the building phase. The exception was:
ExitFailure 1
gloss-examples-1.0.0.0 depends on gloss-1.0.0.0 which failed to install.