Build #1 for gtk-0.11.1

[all reports]

Package gtk-0.11.1
Install DependencyFailed glib-0.11.2
Docs NotTried
Tests NotTried
Time submitted unknown
Compiler ghc-7.6.3
OS linux
Arch x86_64
Dependencies pango-0.11.2, mtl-2.1.2, haskell98-2.0.0.2, glib-0.11.2, gio-0.11.1, containers-0.5.0.0, cairo-0.11.1, bytestring-0.10.0.2, base-4.6.0.1, array-0.4.0.1
Flags have-gio deprecated

Build log

[view raw]

Resolving dependencies...
Downloading cairo-0.11.1...

/tmp/cairo-0.11.1-15133/cairo-0.11.1/Gtk2HsSetup.hs:25:2:
     warning: #warning Setup.hs is guessing the version of Cabal. If compilation of Setup.hs fails use -DCABAL_VERSION_MINOR=x for Cabal version 1.x.0 when building (prefixed by --ghc-option= when using the 'cabal' command) [-Wcpp]
[1 of 2] Compiling Gtk2HsSetup      ( /tmp/cairo-0.11.1-15133/cairo-0.11.1/Gtk2HsSetup.hs, /tmp/cairo-0.11.1-15133/cairo-0.11.1/dist/setup/Gtk2HsSetup.o )

/tmp/cairo-0.11.1-15133/cairo-0.11.1/Gtk2HsSetup.hs:190:70:
    Couldn't match type `PackageDB' with `[PackageDB]'
    Expected type: PackageDBStack
      Actual type: PackageDB
    In the sixth argument of `registerPackage', namely `packageDb'
    In the expression:
      registerPackage
        verbosity installedPkgInfo pkg lbi inplace packageDb
    In a case alternative:
        _ | modeGenerateRegFile -> die "Generate Reg File not supported"
          | modeGenerateRegScript -> die "Generate Reg Script not supported"
          | otherwise
          -> registerPackage
               verbosity installedPkgInfo pkg lbi inplace packageDb
Failed to install cairo-0.11.1

/tmp/glib-0.11.2-15133/glib-0.11.2/Gtk2HsSetup.hs:25:2:
     warning: #warning Setup.hs is guessing the version of Cabal. If compilation of Setup.hs fails use -DCABAL_VERSION_MINOR=x for Cabal version 1.x.0 when building (prefixed by --ghc-option= when using the 'cabal' command) [-Wcpp]
[1 of 2] Compiling Gtk2HsSetup      ( /tmp/glib-0.11.2-15133/glib-0.11.2/Gtk2HsSetup.hs, /tmp/glib-0.11.2-15133/glib-0.11.2/dist/setup/Gtk2HsSetup.o )

/tmp/glib-0.11.2-15133/glib-0.11.2/Gtk2HsSetup.hs:190:70:
    Couldn't match type `PackageDB' with `[PackageDB]'
    Expected type: PackageDBStack
      Actual type: PackageDB
    In the sixth argument of `registerPackage', namely `packageDb'
    In the expression:
      registerPackage
        verbosity installedPkgInfo pkg lbi inplace packageDb
    In a case alternative:
        _ | modeGenerateRegFile -> die "Generate Reg File not supported"
          | modeGenerateRegScript -> die "Generate Reg Script not supported"
          | otherwise
          -> registerPackage
               verbosity installedPkgInfo pkg lbi inplace packageDb
Failed to install glib-0.11.2
cabal: Error: some packages failed to install:
cairo-0.11.1 failed during the configure step. The exception was:
ExitFailure 1
gio-0.11.1 depends on glib-0.11.2 which failed to install.
glib-0.11.2 failed during the configure step. The exception was:
ExitFailure 1
gtk-0.11.1 depends on glib-0.11.2 which failed to install.
pango-0.11.2 depends on glib-0.11.2 which failed to install.