Build #8 for hack-handler-cgi-0.2.0.2

[all reports]

Package hack-handler-cgi-0.2.0.2
Install DependencyFailed hack-2009.10.30
Docs NotTried
Tests NotTried
Time submitted 2016-12-25 21:51:48.709219 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, bytestring-0.9.2.1, hack-2009.10.30
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring data-default-class-0.1.2.0...
Configuring bytestring-0.9.2.1...
Building bytestring-0.9.2.1...
Building data-default-class-0.1.2.0...
Installed data-default-class-0.1.2.0
Configuring dlist-0.8.0.2...
Building dlist-0.8.0.2...
Configuring old-locale-1.0.0.7...
Installed dlist-0.8.0.2
Building old-locale-1.0.0.7...
Configuring data-default-instances-containers-0.0.1...
Installed old-locale-1.0.0.7
Building data-default-instances-containers-0.0.1...
Installed bytestring-0.9.2.1
Configuring data-default-instances-dlist-0.0.1...
Building data-default-instances-dlist-0.0.1...
Configuring data-default-instances-old-locale-0.0.1...
Installed data-default-instances-containers-0.0.1
Building data-default-instances-old-locale-0.0.1...
Installed data-default-instances-dlist-0.0.1
Installed data-default-instances-old-locale-0.0.1
Configuring data-default-0.7.1.1...
Building data-default-0.7.1.1...
Installed data-default-0.7.1.1
Configuring hack-2009.10.30...
Building hack-2009.10.30...
Failed to install hack-2009.10.30
Build log ( /home/builder/.cabal/logs/hack-2009.10.30.log ):
cabal: Entering directory '/tmp/cabal-tmp-27071/hack-2009.10.30'
Warning: hack.cabal: Unknown fields: build-depends (line 13)
Fields allowed in this section:
name, version, cabal-version, build-type, license, license-file,
license-files, copyright, maintainer, stability, homepage,
package-url, bug-reports, synopsis, description, category, author,
tested-with, data-files, data-dir, extra-source-files,
extra-tmp-files, extra-doc-files
Configuring hack-2009.10.30...
Building hack-2009.10.30...
Preprocessing library hack-2009.10.30...
[1 of 1] Compiling Hack             ( src/Hack.hs, dist/build/Hack.o )

src/Hack.hs:28:10: error:
    • Illegal instance declaration for ‘Show HackErrors’
        (All instance types must be of the form (T a1 ... an)
         where a1 ... an are *distinct type variables*,
         and each type variable appears at most once in the instance head.
         Use FlexibleInstances if you want to disable this.)
    • In the instance declaration for ‘Show HackErrors’
cabal: Leaving directory '/tmp/cabal-tmp-27071/hack-2009.10.30'
cabal: Error: some packages failed to install:
hack-2009.10.30 failed during the building phase. The exception was:
ExitFailure 1
hack-handler-cgi-0.2.0.2 depends on hack-2009.10.30 which failed to install.