The hack2-handler-mongrel2-http package

[Tags:bsd3, library]

Hack2 Mongrel2 HTTP handler


[Skip to Readme]

Properties

Versions 2011.6.22, 2011.6.24, 2011.6.25, 2011.10.31
Change log changelog.md
Dependencies aeson, air, attoparsec, base (>=4.0 && <100), blaze-builder, blaze-textual, bytestring, containers, data-default (>=0.2), directory, enumerator, hack2 (>=2011.6.20), mtl, network, safe, stm, text, unix, zeromq-haskell [details]
License BSD3
Author Jinjing Wang
Maintainer Jinjing Wang <nfjinjing@gmail.com>
Stability Unknown
Category Web
Home page https://github.com/nfjinjing/hack2-handler-mongrel2-http
Uploaded Mon Oct 31 10:21:48 UTC 2011 by JinjingWang
Distributions NixOS:2011.10.31
Downloads 786 total (11 in the last 30 days)
Votes
0 []
Status Docs not available [build log]
All reported builds failed as of 2015-11-12 [all 7 reports]

Modules

  • Hack2
    • Handler
      • Hack2.Handler.Mongrel2HTTP

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Readme for hack2-handler-mongrel2-http

Readme for hack2-handler-mongrel2-http-2011.10.31

Serving Hack2 application with the great Mongrel2 server

  • enumerator enabled, constant memory consumption when enumerator all the way down

How to run

  • install mongrel2
  • install GHC
  • install cabal-install
<br />
cabal update
cabal install nemesis
cabal install hack2-handler-mongrel2-http
cabal install hack2-contrib

git clone https://github.com/nfjinjing/hack2-handler-mongrel2-http.git

cd hack2-handler-mongrel2-http

# load a mongrel config, for more information, see the Nemesis task file
nemesis load

# start a mongrel server, port is 6767
nemesis start

# start a hello world hack2 app using mongrel2 handler
nemesis run

now visit: http://localhost:6767, you should see a hello world page.

Monkey fix the Dependency Hell

  • add what you need into hack2-handler-mongrel2-http.cabal and cabal install, this will make sure the correct version of your libraries are pre-linked with mongrel2-http.

Useful getting started resource