hackage-index: Utility for accessing hackage index

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain]

This package provides the tool hit (short for Hackage index tool) for performing queries on the package index. hit is designed as a companion tool to cabal and consequently directly reuses cabal's package index cache.

Properties

Version0.1.0.0
Change logNone available
Dependenciesaeson (>=1.3.1.1 && <1.4 || >=1.4.0.0 && <1.5), base (>=4.8.2.0 && <4.9 || >=4.9.1.0 && <4.10 || >=4.10.1.0 && <4.11 || >=4.11.1.0 && <4.12 || >=4.12.0.0 && <4.13), base-encoding (>=0.1.0.0 && <0.2), bytestring (>=0.10.6.0 && <0.11), Cabal (>=2.4.1.0 && <2.5), containers (>=0.5.6.2 && <0.6 || >=0.6.0.1 && <0.7), cryptohash-sha256 (>=0.11.101.0 && <0.12), deepseq (>=1.4.1.1 && <1.5), directory (>=1.2.3.0 && <1.3 || >=1.3.0.0 && <1.4), filepath (>=1.4.0.0 && <1.5), mtl (>=2.2.2 && <2.3), optparse-applicative (>=0.14.3.0 && <0.15), parsec (>=3.1.13.0 && <3.2), paths (>=0.2.0.0 && <0.3), semigroups (>=0.18.5 && <0.19), sqlite-simple (>=0.4.16.0 && <0.5), tar (>=0.5.1.0 && <0.6), text (>=1.2.3.1 && <1.3), time (>=1.5.0.1 && <1.6 || >=1.6.0.1 && <1.7 || >=1.8.0.2 && <1.9), unordered-containers (>=0.2.7 && <0.3), zlib (>=0.6.2 && <0.7) [details]
LicenseGPL-3.0-or-later
AuthorHerbert Valerio Riedel
Maintainerhvr@gnu.org
CategoryDevelopment
Bug trackerhttps://github.com/hvr/hackage-index/issues
Source repositoryhead: git clone https://github.com/hvr/hackage-index
Executableshit
UploadedSun Feb 24 20:04:35 UTC 2019 by HerbertValerioRiedel

Downloads

Maintainers' corner

For package maintainers and hackage trustees