The hackage-proxy package

[Tags: deprecated, mit, program]

Deprecated

The motivating use case for this is testing packages with newer versions of GHC. In this case, upper bounds on base, process, and a few other packages will often prevent compilation. This proxy will allow you to strip those upper bounds and proceed with compilation. In the future, other features may be added as well, such as package replacement.


Properties

Versions0.1.0.0, 0.2.0.0, 0.2.0.1, 0.2.0.2, 0.3.0, 0.3.0.1
Dependenciesbase (>=4.5 && <5), basic-prelude (>=0.3.6), blaze-builder (>=0.3), bytestring (>=0.9), Cabal (>=1.12), case-insensitive, conduit (>=0.5), containers, filepath, http-conduit (>=1.9), http-types (>=0.7), optparse-applicative (>=0.5), tar (>=0.4), text (>=0.11), transformers (>=0.2), unordered-containers, wai (>=1.3), warp (>=1.3), zlib (>=0.5), zlib-conduit (>=0.5)
LicenseMIT
AuthorMichael Snoyman
Maintainermichael@snoyman.com
CategoryDevelopment
Home pagehttp://github.com/snoyberg/hackage-proxy
Executableshackage-proxy
Upload dateMon Oct 14 05:25:19 UTC 2013
Uploaded byMichaelSnoyman
Downloads396 total (52 in last 30 days)

Downloads

Maintainers' corner

For package maintainers and hackage trustees