The hamsql package

[maintain]

Interpreter for SQL-structure definitions in Yaml (YamSql)


[Skip to ReadMe]

Properties

Versions0.7.0.0, 0.7.0.0, 0.8.0.0, 0.9.0.0
Dependenciesaeson (==1.0.*), base (>=4.8 && <5.0), bytestring (==0.10.*), directory (==1.2.*), file-embed (==0.0.*), filepath (==1.4.*), frontmatter (==0.1.*), groom (==0.1.*), hamsql, network-uri (==2.6.*), optparse-applicative (==0.13.*), pandoc (==1.17.*), postgresql-simple (>=0.4 && <0.6), semigroups (==0.18.*), text (==1.2.*), transformers (==0.5.*), unordered-containers (==0.2.*), yaml (==0.8.*) [details]
LicenseGPL-3
Copyright(c) 2014-2016 Michael Herold et al.
AuthorMichael Herold <quabla@hemio.de>
MaintainerMichael Herold <quabla@hemio.de>
CategoryDatabase
Home pagehttps://git.hemio.de/hemio/hamsql
Bug trackerhttps://git.hemio.de/hemio/hamsql/issues
Source repositoryhead: git clone git@git.hemio.de:hemio/hamsql.git
Executableshamsql
UploadedWed Sep 28 14:56:36 UTC 2016 by quabla

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for hamsql-0.7.0.0

HamSql

Interpreter for SQL-structure definitions in Yaml (YamSql)

Building HamSql on Debian

Install haskell compiler and required libraries:

apt install \
 make \
 ghc \
 cabal-install \
 libghc-aeson-dev \
 libghc-file-embed-dev \
 libghc-network-uri-dev \
 libghc-optparse-applicative-dev \
 libghc-pandoc-dev \
 libghc-postgresql-simple-dev \
 libghc-text-dev \
 libghc-unordered-containers-dev \
 libghc-yaml-dev

Now you can

make
make install

Completly building from sources

apt install make ghc cabal-install libpq-dev happy
make