Build #9 for hasloGUI-0.1

[all reports]

Package hasloGUI-0.1
Install DependencyFailed wtk-0.2.1
Docs NotTried
Tests NotTried
Time submitted 2016-12-24 11:30:35.694096 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies QuickCheck-2.9.2, base-4.9.0.0, convertible-1.1.1.0, gtk-0.14.6, haslo-0.1.3, lenses-0.1.7, mtl-2.2.1, old-time-1.1.0.3, time-1.6.0.1, wtk-0.2.1, wtk-gtk-0.2
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring mtl-2.2.1...
Configuring old-locale-1.0.0.7...
Building old-locale-1.0.0.7...
Building mtl-2.2.1...
Installed old-locale-1.0.0.7
Configuring primitive-0.6.1.0...
Building primitive-0.6.1.0...
Installed mtl-2.2.1
Configuring random-1.1...
Building random-1.1...
Configuring primitive-0.6.2.0...
Installed primitive-0.6.1.0
Building primitive-0.6.2.0...
Configuring utf8-string-1.0.1.1...
Installed random-1.1
Building utf8-string-1.0.1.1...
Configuring text-1.2.2.1...
Installed utf8-string-1.0.1.1
Building text-1.2.2.1...
Configuring old-time-1.1.0.3...
Installed primitive-0.6.2.0
Building old-time-1.1.0.3...
Configuring wtk-0.2.1...
Installed old-time-1.1.0.3
Building wtk-0.2.1...
Failed to install wtk-0.2.1
Build log ( /home/builder/.cabal/logs/wtk-0.2.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-19099/wtk-0.2.1'
Configuring wtk-0.2.1...
Building wtk-0.2.1...
Preprocessing library wtk-0.2.1...
[1 of 4] Compiling Text.WtkParser   ( Text/WtkParser.hs, dist/build/Text/WtkParser.o )

Text/WtkParser.hs:36:10: error:
    • No instance for (Applicative Parser)
        arising from the superclasses of an instance declaration
    • In the instance declaration for ‘Monad Parser’

Text/WtkParser.hs:46:10: error:
    • No instance for (GHC.Base.Alternative Parser)
        arising from the superclasses of an instance declaration
    • In the instance declaration for ‘MonadPlus Parser’
cabal: Leaving directory '/tmp/cabal-tmp-19099/wtk-0.2.1'
Configuring lenses-0.1.7...
Building lenses-0.1.7...
Configuring tf-random-0.5...
Failed to install lenses-0.1.7
Build log ( /home/builder/.cabal/logs/lenses-0.1.7.log ):
cabal: Entering directory '/tmp/cabal-tmp-19092/lenses-0.1.7'
Configuring lenses-0.1.7...
Building lenses-0.1.7...
Preprocessing library lenses-0.1.7...
[1 of 2] Compiling Data.Lenses      ( src/Data/Lenses.hs, dist/build/Data/Lenses.o )
[2 of 2] Compiling Data.Lenses.Template ( src-25/Data/Lenses/Template.hs, dist/build/Data/Lenses/Template.o )

src-25/Data/Lenses/Template.hs:101:18: error:
    • The constructor ‘DataD’ should have 6 arguments, but has been given 5
    • In the pattern: DataD _ _ params cons' _
      In a case alternative:
          DataD _ _ params cons' _ -> return (params, cons')
      In a stmt of a 'do' block:
        (params, cons) <- case reified of {
                            DataD _ _ params cons' _ -> return (params, cons')
                            NewtypeD _ _ params con' _ -> return (params, [con'])
                            _ -> fail errmsg }
cabal: Leaving directory '/tmp/cabal-tmp-19092/lenses-0.1.7'
Building tf-random-0.5...
Configuring vector-0.11.0.0...
Installed tf-random-0.5
Building vector-0.11.0.0...
Configuring QuickCheck-2.9.2...
Installed text-1.2.2.1
Building QuickCheck-2.9.2...
Installed QuickCheck-2.9.2
Configuring convertible-1.1.1.0...
Building convertible-1.1.1.0...
Configuring parsec-3.1.11...
Installed vector-0.11.0.0
Building parsec-3.1.11...
Configuring hashable-1.2.4.0...
Installed parsec-3.1.11
Building hashable-1.2.4.0...
Installed convertible-1.1.1.0
Installed hashable-1.2.4.0
Configuring hashtables-1.2.1.0...
Building hashtables-1.2.1.0...
Installed hashtables-1.2.1.0
Configuring gtk2hs-buildtools-0.13.2.1...
Building gtk2hs-buildtools-0.13.2.1...
Installed gtk2hs-buildtools-0.13.2.1
Configuring glib-0.13.4.1...
Configuring cairo-0.13.3.1...
Building glib-0.13.4.1...
Building cairo-0.13.3.1...
Installed cairo-0.13.3.1
Installed glib-0.13.4.1
Configuring pango-0.13.3.1...
Configuring gio-0.13.3.1...
Building gio-0.13.3.1...
Building pango-0.13.3.1...
Installed pango-0.13.3.1
Installed gio-0.13.3.1
Configuring gtk-0.14.6...
Building gtk-0.14.6...
Installed gtk-0.14.6
cabal: Error: some packages failed to install:
haslo-0.1.3 depends on wtk-0.2.1 which failed to install.
hasloGUI-0.1 depends on wtk-0.2.1 which failed to install.
lenses-0.1.7 failed during the building phase. The exception was:
ExitFailure 1
wtk-0.2.1 failed during the building phase. The exception was:
ExitFailure 1
wtk-gtk-0.2 depends on wtk-0.2.1 which failed to install.